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General Setup Instructions

GX-9100 Graphic Configuration Software (also referred to
as GX Tool) is used to configure the DX-9100 Extended
Digital Plant Controller, the XT-9100 and XTM-905
Extension Modules, and the DX LCD Display. The GX Tool
is part of the M-Tool suite of programming tools.
This manual has been written with the assumption that the
reader is familiar with the DX-9100, XT-9100, XTM-905,
and DX LCD Display.
The DX-9100 processes the analog and digital input signals
it receives, using 12 multipurpose programmable function
modules, a software-implemented Programmable Logic
Controller (PLC), time schedule modules, and optimal
start/stop modules to produce the required outputs,
depending on the module configuration, operating
parameters, and programmed logic.
The DX-9100 can accept eight analog inputs and eight
digital inputs.  It provides up to 14 output modules, which
are configured to give eight analog outputs (two analog
outputs in the Version 1 controller) and six digital outputs
(triacs).  The triacs can be separately configured to provide
six on/off or pulse outputs, six duration adjust outputs, three
position adjust (incremental) outputs, three start/stop
outputs, or any combination using up to six triacs.
The DX-9100 input/output can be extended by up to 64
remote inputs/outputs, analog or digital, depending on the
type of the connected XT-9100 or XTM-905 extension
module configurations.
Each XT/XTM with an XP module can provide either eight
analog points or eight digital points.  An XT/XTM can be
expanded to provide eight additional digital points in one
physical configuration by connecting two XP modules to the
XT/XTM module.

Introduction
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The Version 3.x controller (LonWorks DX-912x) can
receive and transmit analog and digital data over the
network to other Version 3.x controllers.  Each controller
accommodates 16 network analog inputs, 16 network analog
outputs, 8 blocks of 16 digital inputs, and 8 blocks of 16
digital outputs.  Network inputs and outputs allow
DX-912xcontrollers to share data on a LonWorks N2 trunk
without the need for a supervisory controller.
A configuration comprises a set of parameters for each
module, which are stored in a series of memory locations in
the controller.  Through the GX Tool, each module is
assigned a type, details are entered in its data window, and
outputs (source points) are connected to the inputs
(destination points) of other modules.  The PLC requires the
generation of a logic diagram using different types of logic
instructions.
The DX LCD Display unit is configured to display up to 96
data points from the DX controller configuration.  It also
displays alarm data, time schedules, trend logs, and
user-defined graphic screens. The GX-9100 is used to select
data points for display and to define user text for all its
various screens.
Finally, all the information is downloaded to the controller
and the DX LCD Display unit.  Information uploaded from
the controller may also be displayed via the GX Tool.

Refer to Table 1 for additional information:

Table 1: Related Information
Document Title Code Number
DX LCD Display Technical Bulletin MN-9100-2123

DX-9100 Configuration Guide MN-9100-4103

Using a Template File section of the
EuroPRO for Windows User's Guide

MET-CTW-04

XTM-905, XPx-xxx Technical Bulletin MN-9100-2122
XT-9100 Extension Module, XP-910x
Expansion Modules Technical Bulletin

MN-9100-2111

LONWORKS N2 Bus Technical Bulletin LIT-6364100
M-Tool Overview and Installation
Technical Bulletin

LIT-693100

Related
Information
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The following system components are needed to run the
Microsoft Windows version of the GX Tool:
� IBM AT, PS/2, or 100% compatible computer
� minimum of a 486 processor (Pentium recommended)
� minimum of 32 Mb of RAM, with Windows running
� minimum of 5.0 Mb of hard disk space
� a CD ROM drive (for installation)
� Microsoft Windows, Version 3.1 or later. (If using

System Tools software, Windows 98 or later is required.
See note below.)

� an RS-232 port (for downloading to or uploading from
the controller)

� a printer for graphics and text
� a Windows compatible mouse

Note: If you plan to download or upload through an N30
Supervisory Controller, additional System Tools
software must be installed, and system requirements
may change. Refer to the M-Tool Overview and
Installation Technical Bulletin (LIT-693100) for
details.

Refer to the M-Tool Overview and Installation Technical
Bulletin (LIT-693100) for software installation details.
The installation procedure automatically creates or modifies
an initialization file named GX9100.INI.  It  sets up the
program group called Configuration Tools, and the icons
needed for running the GX-9100 utilities, which are
listed in Table 2. An icon for the GX-9100 readme file is
also created.

System
Requirements

Software
Installation
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Table 2:  GX-9100 Utilities
Icon Description Document
GX-9100 Configuring the DX-9100 Controller, the XT-

9100 and XTM-905 Extension Modules, and
the DX LCD Display.

GX-9100 Software
Configuration Tool
User’s Guide,
MET-CTW-05, or
FANs 636.4 and 1628.4

DX
Commissioning

Point template program to commission the
DX-9100 Controller, including:  obtaining
controller information, monitoring points and
control loops, and overriding and adjusting
points.

Using a Template File
section of the EuroPRO
for Windows User’s
Guide, MET-CTW-04,
or FANs 636.4
and 1628.4

NDM
Configuration

Creating configuration files for the N2 Dialer
Module (NDM), and related procedures.

NDM Configurator
Application Note,
MET-CTW-06, or
FANs 636.4 and 1628.4

The installed language file set determines the default
temperature units, frequency, and language.  To switch
languages and program defaults without having to reinstall
the GX Tool:
1. Copy the file GXRES.* to GXRES.DDL
2. Copy the file DXMISC.* to DXMISC.LNG
3. Copy the file DXTEXT.* to DXTEXT.LNG
Note: The * indicates the file extension that is the first three

letters of the language/defaults to which you are
switching.

To enable the download/upload password protection feature
in the GX Tool, use a standard text editor, such as Windows
Notepad, to add the following entry in the [Settings] section
of the GX9100.INI file (located in the windows directory):
[Settings]
PasswordEnable=Yes
Note: Be sure to use a capital Y when entering Yes.
If the entry is not present in the GX9100.INI file, then the
password protection feature is disabled by default, and the
DX Password fields are not shown in the Download and
Upload dialog boxes.

Switching
Languages/
Defaults

Enabling
Password
Protection for
the DX-9100
Download/
Upload
Dialogs (DX
Version 1.4,
2.3, or 3.3 or
later)
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Note: If the [Settings] section is not present, add it, using
square brackets as shown above.

To change the controller version that is chosen by default in
the GX Tool, use a standard text editor, such as Windows
Notepad, to add or change the following entry in the
[Settings] section of the GX9100.INI file (located in the
windows directory):
[Settings]
DefaultControllerVersion=<version number>
Valid entries for the <version number> parameter are:
1.1, 1.2, 1.3, 1.4, 2.0, 2.1, 2.2, 2.3, 2.4, 3.0, 3.1, 3.2, 3.3 and
3.4
If <version number> is set to any value other than those
listed above, or if the entry is not present in the GX9100.INI
file, then the GX Tool defaults to Version 2.4.
Note: If the [Settings] section is not present, add it, using

square brackets as shown above.

A DT-9100 with firmware Version 3.00.00 or higher can be
updated via Update Firmware under the DX LCD Display
menu. This feature is only available when "Yes" has been
entered in the [Firmware Download] section of the
GX9100.INI file (located in the windows directory), as
follows:
[Firmware Download]
AllowFirmwareUpdate=Yes

Changing the
Default
Controller
Version

Enabling the
Firmware
Update for the
DT-9100
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When the GX Tool is running in a PC with M-Tool
software, including the Loader User Interface program, and
the PC is connected to a network of N30 supervisory
controllers, a DX controller on the N2 Bus of any N30 may
be downloaded or uploaded over the network. This feature is
only available when "Yes" has been entered in the [Settings]
section of the GX9100.INI file (located in the windows
directory), and a path to the Loader User Interface program
<LoaderUI.exe> had been defined as follows:
[Settings]
N30Download=Yes
N30Executable=<path of the LoaderUI.exe program>

The default second line entry is shown below:
N30Executable=C:\Program Files\Johnson Controls\System Tools\loaderui.exe

If the entry is not preset in the GX9100.INI file, or the entry
is "No", then the Load via N30 and Upload via N30 menu
items are grayed out in the Action menu.
Note: If the [Settings] section is not present, add it, using

square brackets as shown above.

To start the GX Tool software, from the Start menu, select
Programs>Configuration Tools>GX-9100.

There are two methods of connecting the computer to the
DX-9100 Controller.  For more information, refer to the
DX-9100 Extended Digital Controller Technical Bulletin
(MN-9100-2110) in the System 91 Manual.
Local Access connection from the computer to the
DX-9100, Version 1 or 2, is made via an IU-9100 or
MM-CVT-101 converter unit that, in turn, must be
connected to the N2 Bus (Bus 91) on which the DX-9100
controller resides.
Note: The controller must be disconnected from the

supervisory system.

Enabling
Download and
Upload via the
N30 Controller

Program
Start

Connection
to the
DX-9100
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With this connection configuration, each DX-9100 with its
connected XT-9100 and XTM-905 modules, and any
XT-9100 modules on the bus can be downloaded, one after
the other, with the appropriate controller address entered at
the GX-9100 PC.
The DX-9100 Version 2 or 3 controller with its connected
XT-9100 and XTM-905 modules may be downloaded
directly via its RS-232 port.  With this connection
configuration only this one DX-9100 and its XT/XTMs can
be downloaded.
Note: If you have a LonWorks DX (Version 3.x), you

cannot download via the LonWorks trunk from the
GX Tool.  The only way is via the RS-232 port on the
DX-912x controller or through a Metasys OWS.
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Figure 1:  Connection Details for Download
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The serial cable provided with the DX LCD Display unit is
used for downloading the display configuration.  Connect
the 9-pin female plug labeled "DX/PC" to the COM1 or
COM2 serial port of the PC (Figure 2). The telephone-type
connector on the other end of the cable should be plugged
into the phone jack RS232 INPUT on the DX LCD Display.

Personal Computer
(Rear View)

esc

!

DX LCD
Display

9/12 VDC Power Supply
(AC Adapter)

COM1 or COM2
Serial Port

Serial Cable
(Supplied with 

DX LCD Display)

Figure 2:  Connecting the DX LCD Display to the
PC’s Serial Port

Note: Before connecting the serial cable to the PC, switch
on the DX LCD Display and wait for the
download/upload screen to appear.

Connection
to the DX
LCD Display
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Creating a Configuration

The process for configuring a DX controller is shown in the
figure below.

Start the GX-9100 Program

Choose Which Version DX to
Configure

Define Job Information

Define Global Data

Define Analog Inputs and
Digital Outputs

Define Analog Outputs and
Digital Inputs

Define XT, XTM, and EXP Modules

Define Network Inputs and
Outputs (Version 3 only)

Define Programmable Modules

Define PLC Diagrams

Make Connections

Define Trend Log Module

Save the Configuration

Download the Configuration

Figure 3:  DX Configuration Process

Configuration
Process
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To start the GX Tool software, select
Programs>Configuration Tools>GX-9100, and the
following screen appears:

Figure 4:  Main Screen for a DX Version 2.x or 3.x

The mouse or arrow keys are used to move around the
screen.  The mouse is recommended because it is fastest.

Starting the
GX-9100

11:05:30 Friday, October 3, 1997

GX9100 - Untitled

Title Bar
System Menu Box

File Edit View Action Controller Window DX LCD Display Help

AI2
AI3
AI4
AI5
AI6
AI7
AI8

AI1

DI1
DI2
DI3
DI4
DI5
DI6
DI7
DI8

AO1
AO2
AO9

AO10
AO11
AO12
AO13
AO14
DO3
DO4
DO5
DO6
DO7
DO8

6 Digital
Outputs

8 Analog
Outputs

8 Digital
Inputs

8 Analog
Inputs

Menu Bar

Tool Bar

Scroll Bar

Minimize, Maximize,
and Close Buttons

gxstart
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The menu bar is across the top of the main screen.  Click on
a menu item with the left mouse button for a list of
corresponding options to choose from.  The menu bar,
shown below, groups the activities associated with
configuration into eight categories.

File Edit View Action Controller Window DX LCD Display Help
GX9100 - [Untitled]

Figure 5:  Menu Bar

Available options appear in black text.  Options not
available for selection are grayed-out.  To choose an option,
click on it once with the left mouse button.  To leave the
menu without choosing an option, click the left mouse
button once anywhere on the screen outside of the menu. A
detailed description of the items in each menu follows.

Menu Bar
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File Menu

The file menu, shown in Figure 6, contains options to open,
save, and print configuration files.

Exit...

DDL File Options...

Write User Names...
Read User Names...

Header/Footer...
Print Setup...
Print Preview...

Import...

Save As...
Save

Open...
New

File

Print...

Figure 6:  File Menu

Table 3 describes the various file menu options.

Table 3:  File Menu Options
Menu Option Description
New Opens a new configuration file.
Open Opens an existing configuration file.
Import Imports files generated by the DOS GX-9100, Version 2,

configuration tool into the GX Tool.
Save Saves the current configuration.
Save As Saves a copy of the current configuration under a different name.
Print Prints the current configuration.
Print Preview Allows you to view the current configuration as it will be printed on

the page.
Print Setup Allows you to set print parameters, including default printer, portrait

or landscape, paper size and source, and page range.
Header/Footer Allows you to set up user-defined headers and footers.
Read User Names Reads the contents of an existing Tag name ASCII file into a

GX-9100 configuration and modifies the configuration Tag names.
Write User Names Creates a Tag name ASCII file from an existing GX-9100

configuration and saves it to disk.
DDL File Options Allows you to define the items to be written to the DDL files when the

configuration is saved.
Exit Terminates the GX Tool.
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Edit Menu
The Edit menu, shown in Figure 7, contains various options
to create and change configurations.

Clear
Job Information...
Calibration...
Disconnect... F4
Connect... F5
Add Alarm Disable

Delete

Change Module Number...
Data...

Configure
Add PM

Edit

Global Data...

Figure 7:  Edit Menu

Table 4 describes the various Edit menu options.

Table 4:  Edit Menu Options
Menu Option Description
Add PM Brings up a submenu to add one of several types of programmable

modules to the configuration.
Configure Brings up a submenu that allows you to configure the highlighted

module.
Delete Deletes the current module’s configuration.  The module will

remain on the screen.
Data Brings up a data screen with information about the selected

module that can be viewed and edited.
Change Module
Number

Allows you to change the number of the highlighted module.

Global Data Allows you to edit information that affects the whole configuration,
including temperature units, frequency, initialization on power up,
counter type, daylight saving start and end date, password, and
user configuration code.

Add Alarm Disable Adds an alarm disable function block to the configuration.
Connect Connects source and destination points.
Disconnect Disconnects previously made connections.
Calibration Allows you to calibrate analog input and outputs, and trim the

accuracy of the realtime clock.
Job Information Allows you to enter information pertaining to the configuration, such

as job name, controller name, engineer, and branch.
Clear Erases all logic blocks from the PLC ladder diagram.
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View Menu
The View menu, shown in Figure 8, contains various options
to alter the way the configuration appears on screen.

���� Snap to Grid

Show User Names

Show Connections
Show Tag Names

Show All
Show Selected

View

Trace

Figure 8:  View Menu

Table 5 describes the various View menu options.

Table 5:  View Menu Options
Menu Option Description
Show Selected Change the view to only show the modules that are currently

selected and the connections between these modules.  (To select
more than one module at a time, press Ctrl while clicking on each.)

Show All Returns the view to show every module in the configuration.
Show User Names Displays the user-defined names for all modules that have them.
Show Tag Names Displays the predefined tag names for all modules.
Show Connections Shows all connections for the currently selected module.
Trace Creates a graphical trace of all modules connected to a selected

module for easy tracing of a path, without showing lines to and
from other modules.

Snap to Grid Allows snapping boxes to a grid, permitting easier alignment.
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Action Menu
The Action menu (Figure 9) contains options to upload and
download configurations to and from the DX controller.

Figure 9:  Action Menu

Table 6 describes the various Action menu options.

Table 6:  Action Menu Options
Menu Option Description
Upload Uploads a configuration from a DX controller.
Download Downloads a configuration to a DX controller.
*Upload via N30 Uploads a configuration from a DX controller to the PC via an N30

Controller
*Download via N30 Downloads a configuration to a DX controller from the PC via an

N30 Controller
*Note: The menu option must be enabled in the GX9100.INI file. Refer to Software

Installation, earlier in this document.

Controller Menu
The Controller menu (Figure 10) is used to choose the
controller for which you are creating a configuration.

Figure 10:  Controller Menu

Download...
Upload...

Action

Upload via N30...
Download via N30...

gxaction

gxcontm

DX Version 2.0, 2.1, 2.2

DX Version 3.0, 3.1, 3.2
DX Version 2.3, 2.4

DX Version 1.4
DX Version 1.1, 1.2, 1.3

Controller

DX Version 3.3, 3.4



22     Configuration Tools—GX-9100 User’s Guide

Table 7 describes the various Controller menu options.

Table 7:  Controller Menu Options
Menu Option Description

Each option on the Controller menu sets up the initial
screen to create a configuration for the indicated
controller versions, as follows:

DX Version 1.1, 1.2, 1.3 Versions 1.1, 1.2, and 1.3 of the DX controller.
DX Version 1.4 Version 1.4 of the DX controller (supports Trend).
DX Version 2.0, 2.1, 2.2 Versions 2.0, 2.1, and 2.2 of the DX controller.
DX Version 2.3, 2.4 Version 2.3 and 2.4 of the DX controller (supports Trend).
DX Version 3.0, 3.1, 3.2 Versions 3.0, 3.1, and 3.2 of the DX LonWorks controller.
DX Version 3.3, 3.4 Version 3.3 and 3.4 of the DX LonWorks controller

(supports Trend).

Window Menu
The Window menu, shown in Figure 11, allows you to
cascade, tile, or arrange multiple configuration windows on
the screen.

Window

Arrange
Tile
Cascade

Figure 11:  Window Menu

Table 8 describes the various Window menu options.

Table 8:  Window Menu Options
Menu Option Description
Cascade Arranges multiple configurations on the screen in overlapping

“stair-stepped” panes.
Tile Arranges multiple configurations into equal-sized panes that fill the

screen but do not overlap.
Arrange Arranges icons and windows on the screen.

DX LCD Display Menu
See DX LCD Display Menu under Configuring the DX LCD
Display - User Interface later in this manual.
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Help Menu
The Help menu, shown in Figure 12, is used to call up a
separate window containing an index of GX Tool-related
help topics, to launch a separate Microsoft Windows help
window, and to view the copyright screen.

Figure 12:  Help Menu

Table 9 describes the Help menu options.

Table 9: Help Menu Options
Menu Option Description
GX9100 Help Topic Launches a help window with an index of GX-related topics.
Help Using… Launches window containing help topics for Microsoft Windows

help.
About Displays copyright and version information for the GX Tool.

gxhelpm

About 
Help Using...
GX9100 Help Topic

Help
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The GX Tool help window, shown below, can be launched
by selecting GX9100 Help Topics in the Help Menu, or by
pressing <F1>, or <Shift> and <F1>. The window will
remain open and can be activated via the Microsoft
Windows taskbar. The GX-9100 help window closes
automatically when the GX Tool is closed.

Figure 13:  GX-9100 Help Window
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The Microsoft Windows help window, which shows you
how to use the help function, can be launched by selecting
Help Using… in the Help menu.

Figure 14:  Microsoft Windows Help Window
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The tool bar is located just below the menu bar.  It contains
buttons that perform specific functions when clicked on with
the left mouse button.  Table 10 shows the tool bar buttons
and describes their functions.

Table 10:  Tool Bar Buttons
Tool Bar
Button

Menu Bar
Equivalent

Description

File--New Opens a new configuration file.

File--Open Opens an existing configuration file.

File--Save Saves the current configuration.

Edit--Add
PM

Adds a programmable module or
network input/output module to the
current configuration.

File--Print Brings up the series of print dialog
boxes, which allow you to select items
to print, as well as set print parameters.

Edit--Cut Removes the currently selected data
and places it on the clipboard.

Edit--Copy Places a copy of the currently selected
data on the clipboard.

Edit--Paste Pastes the data from the clipboard into
the currently selected line.

Pop-up menus appear when you use the right mouse button
to click on a point or module.  The pop-up menu that
appears depends on which type of point or module you click
on.  An example of the menu that appears when you click on
an unconfigured Digital Output with the right mouse button
is shown in Figure 15.

Pulse
Sta/Sto
On/Off
D.A.T.
P.A.T.

Figure 15:  Unconfigured Digital Output Pop-Up
Menu Example

Tool Bar

Pop-Up
Menus
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An example of the pop-up menu that appears when you click
on a configured module is shown below.

���� Snap to Grid

Show Connections
Connect... F5

Show User Names
Show Selected

Delete
Data...

Trace

Figure 16:  Configured Module Pop-Up Menu
Example

Select an option by clicking on it with the left mouse button
or highlighting it with the arrow keys, then pressing Enter.
Click the left mouse button outside of the menu or press Esc
to exit the menu without choosing a selection.

Each input and output point, connection source point,
destination point, and programmable module has a
predetermined tag name.  (See the Appendices for details on
these names.)  However, you may define an eight-character
user name that identifies the function of each point and
programmable module in the application being configured.
For programmable modules, inputs, and outputs, define
these names in the data winSdow’s User Name field.  Note
that you can also add a 24-character description in the data
window’s Description field.
For connection points, define the names by clicking on the
Input-Tag button (for destination points) or the Output-Tag
button (for source points) in the appropriate data window,
then enter the names in the fields next to the points.  The
View menu gives you the option to display the configuration
with the predefined tag names or the user names.

User Names
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When started, the DX-9100 initial screen automatically
defaults to Version 2.4.  If you are using a different version
controller, you can change the screen to reflect the desired
format.
To switch between the versions:
1. Click on Controller in the menu bar.  The following

menu appears.

Figure 17:  Controller Menu

The current controller version is the checked menu item.
2. Select another controller version from the menu.  The

screen will change to reflect that version.
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AI2
AI3
AI4
AI5
AI6
AI7
AI8

AI1

DI1
DI2
DI3
DI4
DI5
DI6
DI7
DI8

AO1
AO2

2 Analog
Outputs

8 Digital
Inputs

8 Analog
Inputs

DO3
DO4
DO5
DO6
DO7
DO8

6 Digital
Outputs

Figure 18:  Main Screen for a DX Version 1.x

Choosing
Which DX
Version to
Configure

gxdefltm

DX Version 2.0, 2.1, 2.2

DX Version 3.0, 3.1, 3.2
DX Version 2.3, 2.4

DX Version 1.4
DX Version 1.1, 1.2, 1.3

Controller

DX Version 3.3, 3.4
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To define job information for a configuration:
1. Select Job Information from the Edit menu.  The

following dialog box will appear:
Job Information

Job Name:

Controller Name: Cancel

OK

Engineer:

Project Description:

Branch:

Date (YYYY/MM/DD): 1997 / 10 / 19

Figure 19:  Job Information Dialog Box

2. Fill in the empty data fields.  Note that the current date is
automatically entered into the date field if it has not been
entered previously.

3. Click on OK when you are finished.

Defining Job
Information
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To define the configuration’s global data:
1. Select Global Data from the Edit menu.  The following

dialog box appears:
Edit Global Data

Cancel

OKFrequency

60 Hertz
50 Hertz

Temperature Units

Fahrenheit
Celsius

Counter Type

4 byte
15 bit

Init On Power Up

cancelled
maintained

/DL Saving Start Date (MM/DD)

DL Saving End Date (MM/DD)

0

Password

User Config Code

0

/0 0

0000

Figure 20:  Edit Global Data Dialog Box

2. Fill in the empty data fields.
Notes: The User Configuration Code may be entered as a

number between 0 and 9999 to identify the
configuration being edited. The User Configuration
Code is also downloaded and displayed on the front
panel of the DX controller upon startup (Version 1.1
or later). (The GX Tool will accept numbers up to
65535, but only numbers up to 9999 will be correctly
displayed on the DX front panel.) The User
Configuration Code is also used by the DX LCD
Display unit to identify the configuration so that it
can display the correct screens.
The Password is used to protect a configuration
when loaded into a controller.  Once the password
has been downloaded into the controller along with
the configuration, the controller only allows another
download or upload when the same password is
entered in the Download or Upload dialog box.
Enter a password of 0000 to disable the password
function.

Defining the
Global Data
and
Password
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The Password field is grayed and cannot be edited if the
password feature has not been enabled in the
GX9100.INI file (see Enabling Password Protection for
the DX-9100 Download/Upload Dialogs under Software
Installation at the beginning of this guide).

3. Click on OK to save the values and close the dialog box.

Defining analog inputs and digital outputs is a two-step
process.  First configure the AI or DO using the pop-up
menus.  Then use the data windows to define the data
associated with the AI or DO.

To configure an analog input or digital output:
1. Use the right mouse button to click on the AI or DO to

be configured.  Examples of the pop-up menus are
shown below.

Pulse
Sta/Sto
On/Off
D.A.T.
P.A.T.

Passive
Active

Digital Output
Pop-up Menu

Analog Input
Pop-up Menu

Figure 21:  Analog Input and Digital Output
Configuration Menus

2. Use the left mouse button to select the AI or DO type
from the pop-up menu.  A double border appears around
the point to indicate that it is configured.

Defining
Analog
Inputs and
Digital
Outputs

AI or DO
Configuration
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To define the data associated with the AI or DO:
1. Click on the configured AI or DO with the right mouse

button and select Data from the pop-up menu that
appears, or highlight the point, then select Data from the
Edit menu.  Data windows like the figures shown below
appear.

ANA IN (ACT) (AI1) - Data

User Name

Description
Cancel

OK

Units of Measure: 0 = None, 1 = Temperature, 2 = %
Type of Input: 0 = 0-10 VDC, 1 = 4-20 mA, 2 = 0-20 mA

Output-Tag...

Measurement Units 0
Type of Active Input 0

High Range 100.
Low Range 0.
High Limit 100.

Low Limit 0.
Filter Constant (sec) 0.
Limit Differential 1.

Alarm Unfiltered (0=N) 0
Square Root (0=N) 0

Figure 22:  Active Analog Input Data Window

AI or DO Data
Definition
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P.A.T. (DO3) - Data

User Name

Description
Cancel

OK

Output-Tag...

Source Point -->

Stroke Time (Sec) 90.
Deadband (%) 1.

Input-Tag...

High Range 100.
Low Range 0.

Feedback -->

Output Forcing -->

Enable Limits -->

Increase Source -->

Decrease Source -->

High Limit (%) 100.

Low Limit (%) 0.
Forcing Level (%) 100.
Hold on Powerup (0=N) 0

Auto on Powerup (0=N) 0

Figure 23:  P.A.T. Digital Output Data Window

2. Enter the desired values in the empty data fields.  Use an
asterisk (*) to make or modify connections from the data
windows.

3. Click on the Input-Tag button to assign user names to
the destination points (if applicable).

4. Click on the Output-Tag button to assign user names to
the source points (if applicable).

5. Click on OK when you are finished entering data to save
the values and exit the data window.
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To define analog outputs and digital inputs, you only need to
enter the data associated with the AO or DI.
To enter the associated data:
1. Click on the configured AO or DI with the right mouse

button and select Data from the pop-up menu that
appears, or highlight the point, then select Data from the
Edit menu.  Data windows like the figures shown below
appear.

ANALOG OUT (AO1) - Data

User Name

0 = Disabled
1 = 0-10 VDC
2 = 0-20 mA
3 = 4-20 mA

AO11-AO14: 0-10V only

Description
Cancel

OK

Output-Tag...

Input-Tag...

Low Range 0.
High Limit (%) 100.

Low Limit (%) 0.
Forcing Level (%) 0.
Hold on Powerup (0=N) 0

Auto on Powerup (0=N) 0High Range 100.

Output Forcing -->

Increase Source -->

Decrease Source -->

Type of Output 0
Source Point -->

Figure 24:  Analog Output Data Window

DIGITAL IN (DI1) - Data

User Name

Description
Cancel

OK

Output-Tag...

Prescaler (counts) 1

Figure 25:  Digital Input Data Window

2. Enter the desired values in the empty data fields.  Use an
asterisk (*) to make or modify connections from the data
windows.

3. Click on the Input-Tag button to assign user names to
the destination points (if applicable).

Defining
Analog
Outputs and
Digital Inputs
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4. Click on the Output-Tag button to assign user names to
the source points (if applicable).

5. Click on OK when you are finished entering data to save
the values and exit the data window.

Table 11 shows the maximum number of each type of
module that can be used in a configuration.

Table 11:  Module Type Limits
Type of Module Maximum Number Allowed

Control
Numeric

Totalization 12 total
Sequencer

Binary Sequencer
XT or XTM 8 total

Time Schedule 8
PLC 8

Optimum Start/Stop 2
Analog Constants 1
Digital Constants 1

Exception Days 1
LRS1-32 1

LRS33-64 1
Trend Log 1

Network Modules
NDO 8
NDI 8

NAO 16
NAI 16

Note: Once you reach a module’s limit, that module type is
removed from the Add PM menu.  Also, module types
not supported by the selected controller version do not
appear on the Add PM menu.

Defining
Modules
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To configure XT and XTM modules:
1. Click on the Add PM button  on the tool bar, or select

Add PM from the Edit menu.
2. Select XT or XTM from the Add PM menu.  A submenu

appears with options for the XP type (Figure 26 and
Figure 27).  XPs and XTMs can be analog, digital, or
expanded digital.

Note: The XP expanded digital options (preceded with EXP)
only appear if the preceding module is the same
module type (XT or XTM) and the XP type is not
defined as EXP.

The inputs/outputs of an XT or XTM are connected to
the first XP module.  An expanded digital XT or XTM
(EXP) represents the inputs/outputs of the second XP on
the preceding XT or XTM.

Optimum Start Stop

Sequencer
Totalization

Network Modules
Binary Sequencer

Numeric
Control

Time Schedule

Digital Constants
Analog Contstants

PLC
Exception Days

LRS33-64
LRS1-32

Trend
XTM
XT

EXP 8DO
EXP 8DI
EXP 4DI 4DO
8DO
8DI
4DI 4DO
6AI 2AO

Figure 26:  XT Extension Module Configuration
Menus

Defining XT,
XTM, and XP
Modules
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Optimum Start Stop

Sequencer
Totalization

Network Modules
Binary Sequencer

Numeric
Control

Time Schedule

Digital Constants
Analog Contstants

PLC
Exception Days

LRS33-64
LRS1-32

Trend
XTM
XT

EXP
XPE
XPL
XPM
8DO
8DI
4DI 4DO
Analog

6AI 2AO
8AO
8AI
4AI 4AO
4AO
4AI

Figure 27:  XTM Extension Module Configuration
Menus

For an XT module, there is only one type of analog XP
module:  six analog inputs and two analog outputs
(6AI 2AO).
For an XTM module, there are several choices of analog XP
modules, as shown in Table 12 below:

Table 12:  XTM Analog Modules
Menu Option Description
4AI four analog inputs
4AO four analog outputs
4AI 4AO four analog inputs and four analog outputs

(requires 2 XP modules)
8AI eight analog outputs (requires 2 XP modules)
8AO eight analog outputs (requires 2 XP modules)
6AI 2AO six analog inputs and two analog outputs

Configuring
Analog
Modules
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To configure an analog input for an XT or XTM:
1. Select XT or XTM from the Add PM menu.
2. Select the desired analog configuration from the XT or

XTM submenu using the left mouse button.  Additional
analog inputs and outputs will appear around the sides of
the screen (Figure 28).
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AI2
AI3
AI4
AI5
AI6
AI7
AI8

AI1

DI1
DI2
DI3
DI4
DI5
DI6
DI7
DI8

AO1
AO2
AO9

AO10
AO11
AO12
AO13
AO14
DO3
DO4
DO5
DO6
DO7
DO8

XT1AI1
XT1AI2
XT1AI3
XT1AI4
XT1AI5
XT1AI6

XT1AO7
XT1AO8

Outputs added
for XT module.

Inputs added for
XT module.

XT1

Figure 28:  XT Analog Inputs and Outputs

Note: Input and output tags for XTM modules are the same
as for XT modules (e.g., XTnAIm, XTnAOm).

3. Use the mouse to place the XT or XTM module block on
the screen, then click the left mouse button.

4. Click on the desired XTnAIm with the right mouse
button.  The menu shown below (Figure 29) appears:

Passive
Active

Figure 29:  XT/XTM Analog Input Configuration
Menu

5. Click on Active or Passive with the left mouse button to
configure the analog input.  A double border appears in
the AI’s function block to indicate that it is configured.
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To define the data associated with XT or XTM analog inputs
and outputs:
1. Click on the configured XT AI or XT AO with the right

mouse button and select Data from the pop-up menu that
appears, or highlight the point, then select Data from the
Edit menu.  Data windows similar to Figure 30 and
Figure 31, shown below, appear:

XP-ANA IN (ACT) (XT1AI1) - Data

User Name

Description
Cancel

OK

Units of Measure: 0 = None, 1 = Temperature, 2 = %
Type of Input: 0 = 0-10 VDC, 1 = 4-20 mA, 2 = 0-20 mA

Output-Tag...

Measurement Units 0
Type of Active Input 0

High Range 100.
Low Range 0.
High Limit 100.

Low Limit 0.
Filter Constant (sec) 0.
Limit Differential 1.

Alarm Unfiltered (0=N) 0
Square Root (0=N) 0

Figure 30: XT/XTM Analog Input Data Window

XT AI and AO
Data Definition
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XP-ANALOG OUT (XT2AO1) - Data

User Name

Description
Cancel

OK

High Range 100.
Low Range 0.

Type of Output 0

XPA-4x2 only: ::::::

0 = Disabled
1 = 0-10 VDC
2 = 0-20 mA
3 = 4-20 mA

AO11-AO14: 0-10V only
Output Ramp Time: Units of 500ms for full scale change

Output-Tag...

Input-Tag...

Source Point -->

Output Ramp Time 0

Figure 31:  XT/XTM Analog Output Data Window

2. Enter the desired values in the empty data fields.  Use an
asterisk (*) to make or modify connections from the data
windows.

3. Click on the Input-Tag button to assign user names to
the destination points (if applicable).

4. Click on the Output-Tag button to assign user names to
the source points (if applicable).

5. Click on OK when you are finished entering data to save
the values and exit the data window.
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For XT modules, digital or expanded digital XP modules may
have eight digital inputs (8DI or EXP 8DI), four digital inputs
and four digital outputs (4DI 4DO or EXP 4DI 4DO), or eight
digital outputs (8DO or EXP 8DO), as shown in Figure 32
below:

EXP 8DO
EXP 8DI
EXP 4DI 4DO
8DO
8DI
4DI 4DO
6AI 2AO

Figure 32:  Digital and Expanded Digital Extension
Module Configuration Menu for XT

For XTM modules, digital or expanded digital XP modules of
the type XPM-4x1 (momentary output relays), XPL-4x1
(magnetically latched output relays), or XPE-4x1 (electrically
latched output relays) may also be configured, as shown in
Figure 33 below.  Refer to the XTM-905 Technical Bulletin
(MN-9100-2122) for details of these modules.

EXP
XPE
XPL
XPM
8DO
8DI
4DI 4DO
Analog

XPE
XPL
XPM
8DO
8DI
4DI 4DO

Figure 33:  Digital and Expanded Digital Extension
Module Configuration Menu for XTM

Note: Modules of type XPE-4x4, x=0, 1, 2, or 3, must be
configured as 4DI 4DO, and XPE-4x4, x=4, 5, 6, or 7,
as 8DO.

Configuring
Digital or
Expanded
Digital
Extension
Modules
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To configure digital or expanded digital extension modules:
1. Select XT or XTM from the Add PM menu.
2. Select the desired combination of digital inputs and/or

outputs from the XT/XTM submenu using the left mouse
button.  Additional inputs and/or outputs will appear
around the sides of the screen (Figure 34).

Note: Expanded digital module options (options preceded
with EXP) only appear on the submenu if the
preceding module is the same module type (XT or
XTM) and the XP type is not defined as EXP.
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AO2
AO9

AO10
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DO3
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XT1DI1
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XT1DI3
XT1DI4

XT1DO5
XT1DO6Outputs added
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Inputs added for
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XT1

XT1DO7
XT1DO8

Figure 34:  XT Digital Inputs and Outputs

Note: Input and output tags for XTM modules are the same
as for XT modules (e.g., XTnDIm, XTnDOm).

3. Use the mouse to place the XT or XTM module block on
the screen, then press the left mouse button.

4. For outputs only, click on the desired output with the
right mouse button.  The following menu appears.

Pulse
On/Off

Figure 35:  XT/XTM Digital Output Configuration
Menu
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5. Click on On/Off or Pulse with the left mouse button to
configure the digital output.  A double border appears in
the DO’s function block to indicate that it is configured.

Note 1: Configure all DOs as On/Off or Pulse regardless of
whether they are used.  The only exceptions are
the 4-output relay modules (XP-9106 and
XPE-4x4, x=4, 5, 6, or 7).  When only one
4-output module is installed, select 8DO, but
only configure DO1-DO4.  When two 4-output
modules are installed, configure both as one
8DO module, and configure DO1-DO8.

Note 2: Configure XPM-4x1, XPL-4x1, and XPE-4x1
modules as On/Off.  The action of the outputs is
determined by the hardware, not by the
configuration.

To define the data associated with XT and XTM digital
inputs and outputs:
1. Click on the configured XT DI or XT DO with the right

mouse button and select Data from the pop-up menu that
appears, or highlight the point, then select Data from the
Edit menu.  Data windows similar to Figure 36 and
Figure 37, shown below, appear:

XP-DIGITAL IN (XT1DI1) - Data

User Name

Description
Cancel

OK

Output-Tag...

Prescaler (counts) 1
Digital Input Type 0

XTM only: ::::::

Digital Input Type:
0 - ON/OFF
1 - PULSE

Normally Closed Contact (0=N) 0

Figure 36:  XT/XTM Digital Input Data Window

XT DI and DO
Data Definition
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XP-ON/OFF (XT1DO5) - Data

User Name

Description
Cancel

OK

Source Point -->

Output-Tag...

Input-Tag...

Figure 37:  XT/XTM Digital Output Data Window

2. Enter the desired values in the empty data fields.  Use an
asterisk (*) to make or modify connections from the data
windows.

3. Click on the Input-Tag button to assign user names to
the destination points (if applicable).

4. Click on the Output-Tag button to assign user names to
the source points (if applicable).

5. Click on OK when you are finished entering data to save
the values and exit the data window.

To define the data associated with the operation of the
complete XT or XTM module set (including EXP modules):
1. Click on the XT or XTM box with the right mouse

button and select Data from the pop-up menu that
appears, or highlight the module, then select Data from
the Edit menu.  An appropriate data window appears, as
shown in Figure 38 and Figure 39.

XT and XTM
Data Definition
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XT-4DIDO (XT1) - Data

User Name

Description
Cancel

OK

Output-Tag...

Hardware address 0
Status on comm fail 0

Status on comm. failure: 0 = reset to OFF
(Digital Outputs) 1 = maintain status
Dig. Output Pulse Time: Units of 5 msec

Digtl Output Pulse Time 200
Comm. timeout (sec) 60

Figure 38:  XT Data Window

XTM-8DI (XTM2) - Data

User Name

Description
Cancel

OK

Output-Tag...

Hardware address 0
DO status on comm. fail 0

DO status on comm. fail: 0 = reset to OFF
1 = maintain status

DO status after power fail: 0 = reset to OFF
1 = restore previous status

Digital Output Pulse Time: Units of 5 msec

Digital Output Pulse Time 200
Comm. time-out (sec) 60

DO status after power fail 0
Disable Man. Ovr. in Sup. (0=N) 0

Man. Ovr. status in DI1-4 (0=N) 0
Any Ovr. status in DI4 (0=N) 0

For XP1 Only :::::

Figure 39:  XTM Data Window

2. Enter the desired values in the empty data fields.
3. Click on the Output-Tag button to assign user names to

the source points.
4. Click on OK when you are finished entering data to save

the values and exit the data window.
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To configure a programmable module:
1. Click on the Add PM button  on the tool bar, or select

Add PM from the Edit menu.  The Add PM menu shown
in Figure 40 appears.

Optimum Start Stop

Sequencer
Totalization

Network Modules
Binary Sequencer

Numeric
Control

Time Schedule

Digital Constants
Analog Contstants

PLC
Exception Days

LRS33-64
LRS1-32

Trend
XTM
XT

Figure 40:  Programmable Module Configuration
Menu

2. Select the type of module from the menu.  If opting for a
control or numeric module, a submenu appears as shown
in Figure 41.

Defining
Programma-
ble Modules
Configuring
Programmable
Modules
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Optimum Start Stop

Sequencer
Totalization

Network Modules
Binary Sequencer

Numeric
Control

Time Schedule

Digital Constants
Analog Contstants

PLC
Exception Days

LRS33-64
LRS1-32

Trend
XTM
XT

Dual On/Off
Dual PID
On/Off
PID

Optimum Start Stop

Sequencer
Totalization

Network Modules
Binary Sequencer

Numeric
Control

Time Schedule

Digital Constants
Analog Contstants

PLC
Exception Days

LRS33-64
LRS1-32

Trend
XTM
XT

NumericControl

Timer
Eight-Calculator
Calculator
Select

Comparator

Four-Segment
Segment
Psychrometric
Maximum
Minimum
Average

Figure 41:  Control and Numeric Configuration Menus

Once you have selected the type, a highlighted box with
a dashed border and the type name and module number
appears next to the pointing arrow cursor.

3. Place the module on the page by moving it to the desired
position using the mouse, then click the left mouse
button.  You can move the module at any time by
clicking and dragging it to a new position on the screen.

To define the data associated with a programmable module:
1. Click on the programmable module with the right mouse

button and select Data from the pop-up menu that
appears, or highlight the module, then select Data from
the Edit menu.  A data window like the one shown in
Figure 42 appears.

Programmable
Module Data
Definition
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PID (PID1) - Data

User Name

Description
Cancel

OK

Output-Tag...

Input-Tag...

Remote Setpoint -->

Reference Variable -->

Proportional Band -->

OFF Mode Control -->

Standby Control -->

Reverse Action -->ExtForce Out Level 0.

Ena Startup: 0=N 0
Startup Out Level 100.
Ena Symm Mode: 0=N 0

Ena Shutoff: 0=N 0
Shutoff Out Level 0.

Ena PID to P: 0=N 0
Remote Mode: 0=N 0

Ena Off Trans: 0=N 0

Process Variable -->

External Forcing -->
Output Bias -->

Minimum WSP -->

Maximum WSP -->

Data-2...

Figure 42:  PID Module Data Window

2. Enter the desired values in the empty data fields.  Use an
asterisk (*) to make or modify connections from the data
windows.

3. Click on the Input-Tag button to assign user names to
the destination points (if applicable).

4. Click on the Output-Tag button to assign user names to
the source points (if applicable).

5. If the module has two pages, click on the Data-2 button
to access the second page.  An example of the second
page is shown in Figure 43 below.

PID (PID1) - Data-2

Cancel

OKOut High Lmt (HIL) 100.
Out Low Lmt (LOL) 0.
Dev H.H. Limit (DHH) 100.

Dev High Limit (DH) 50.
Dev Low Limit (DL) 50.
Dev L.L. Limit (DLL) 100.Off Mode Bias (BOF) 0.

Reset Action (TI) 0.

Rate Action (TD) 0.
Standby Bias (BSB) 0.

Local Set Pt. (LSP)  0.
Proport. Band (PB) 10.

Symmetry Band (SBC) 5.
Err Deadband (EDB) 5.

Output Bias (OB) 0.

Minimum WSP (MNWS) -50.
Maximum WSP (MXWS) 999.

Figure 43:  PID Module Second Page
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6. Enter the desired values in the empty data fields of the
second window.  Use an asterisk (*) to make or modify
connections from the data windows.

7. Click on OK to save the new values and return to the
first window, or click on Cancel to return to the first
window without saving the values.

8. Click on OK when you are finished to save all values
and exit the data window.

Note: Network modules only appear in configurations for
DX Version 3.x.

To configure a network module:
1. Click on the Add PM button  on the tool bar, or select

Add PM from the Edit menu.
2. Select Network Modules from the menu.  A submenu

appears as shown below.
3. Select Network Analog Input, and a highlighted box

with a dashed border and the name NAIn appears next to
the pointing arrow cursor.

Optimum Start Stop

Sequencer
Totalization

Network Modules
Binary Sequencer

Numeric
Control

Time Schedule

Digital Constants
Analog Contstants

PLC
Exception Days

LRS33-64
LRS1-32

Trend
XTM
XT

Network Digital Output
Network Digital Input
Network Analog Output
Network Analog Input

Figure 44:  Network Modules SubMenu

4. Place the module on the page by moving it to the desired
position using the mouse, then click the left mouse
button.  You can move the module at any time by
clicking and dragging it to a new position on the screen.

Defining
Network
Modules
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5. Follow the same procedure, using the submenu options
Network Digital Input (NDIn), Network Analog Output
(NAOn), and Network Digital Output (NDOn) to define
the network modules.
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Figure 45:  Network Analog and Digital Modules
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To define the data associated with the network analog input
module:
1. Click on the configured NAIn with the right mouse

button and select Data from the pop-up menu that
appears, or highlight the module, then select Data from
the Edit menu.  A data window like the figure shown
below appears.

NETWORK ANALOG INPUT (NAI1) - Data

User Name

Description
Cancel

OK

Output-Tag...

Figure 46:  Network Analog Input Data Window

2. Enter the user name and description as appropriate.
3. Click on the Output-Tag button and assign user names to

the source points as appropriate.
4. Click on OK when you are finished to save all entries

and exit the data window.

Network
Analog Input
Module Data
Definition
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To define the data associated with the network digital input
module:
1. Click on the configured NDIn with the right mouse

button and select Data from the pop-up menu that
appears, or highlight the module, then select Data from
the Edit menu.  A data window like the figure shown
below appears.

NETWORK DIGITAL INPUT (NDI1) - Data

User Name

Description
Cancel

OK

Output-Tag...

Figure 47:  Network Digital Input Data Window

2. Enter the user name and description as appropriate.
3. An Output-Tag can be assigned to each of the 16 binary

points that each NDIn accommodates.  Click on
Output-Tag to enter the appropriate user names as shown
in the figure below.

NETWORK DIGITAL INPUT (NDI1) - Output-Tag

Cancel

OK-1

-2

-3
-4

-5

-6
-7

-8

-9

-10

-11

-12
-13

-14

-15
-16

NDIU

Figure 48:  Network Digital Input (NDIn) Output-Tag
Window

4. Click on OK when you are finished to save all entries
and exit the data window.

Network
Digital Input
Module Data
Definition
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To define the data associated with the network analog output
module:
1. Click on the configured NAOn with the right mouse

button and select Data from the pop-up menu that
appears, or highlight the module, then select Data from
the Edit menu.  A data window like the one shown in
Figure 49 below appears.

NETWORK ANALOG OUTPUT (NAO1) - Data

User Name

Description
Cancel

OK

#1 0
#2

::::::

0

#4 0

Source Pt. -->

Input-Tag...

Data-2...

#3 0

Destination # Cntrl. Addr NAI#

#5 0

#7 0
#6 0

0
0

0
0

0

0
0

Figure 49:  Network Analog Output (NAOn) Data
Window

2. Enter the user name and description as appropriate.
3. Enter the Input-Tag for the source point of the network

analog output.
Note: The network analog output is connected to one source

point in the same DX controller.  Use an asterisk (*)
to make the connections in the data window.

NAOn Destination Definitions
4. Enter the destination controller’s addresses and the

corresponding network analog input points.  Click on
Data-2 to define destination controllers 8-16.

 5. Click on OK when you are finished to save all entries
and exit the data window.

Network
Analog Output
Module Data
Definition
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The NDOn contains up to 16 source binary points.  Make
connections between DX source points and NDOn in the
usual way.
To define network digital outputs:
1. Click on the configured NDOn with the right mouse

button and select Data from the pop-up menu that
appears, or highlight the module, then select Data from
the Edit menu.  A data window like the one shown in
Figure 50 below appears.

NETWORK DIGITAL OUTPUT (NDO1) - Data

User Name

Description
Cancel

OK

Input-Tag...

Data-2...
::::::Source Bit #1 -->

::::::Source Bit #2 -->

::::::Source Bit #3 -->

::::::Source Bit #4 -->

::::::Source Bit #5 -->

::::::Source Bit #6 -->

::::::Source Bit #7 -->

::::::Source Bit #8 -->

::::::Source Bit #9 -->

::::::Source Bit #10 -->

::::::Source Bit #11 -->

::::::Source Bit #12 -->

::::::Source Bit #13 -->

::::::Source Bit #14 -->

::::::Source Bit #15 -->

::::::Source Bit #16 -->

Figure 50:  Network Digital Output (NDOn) Data
Window

2. The connected source points are shown.  Enter the user
name and description as appropriate.

3. Enter Input-Tags for the source points as appropriate.
Note: The NDO contains up to 16 source binary points in

the same DX controller.  Use an asterisk (*) to make
connections between DX source points and NDOn in
the data window.

Network
Digital Output
Module Data
Definition
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NDOn Destination Definitions
1. To define destinations, click on Data-2.  The following

screen appears:
NETWORK DIGITAL OUTPUT (NDO1) - Data-2

Cancel

OK
#1  0
#2 0

#4 0
#3 0

Destination # Cntrl. Addr NDI#

#5 0

#7 0
#6 0

0
0

0
0

0

0
0

#8 0 0

#9 0 0

#11 0
#10 0

#12 0

#14 0
#13 0

0
0

0

0
0

#15 0 0

#16 0 0

Figure 51:  Network Digital Output (NDOn) Data-2
Window

2. Enter the destination controller’s addresses and the
corresponding network digital input points.

3. Click on OK when you are finished to save all entries
and exit the data window.
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The GX-9100’s software-implemented Programmable Logic
Controller (PLC) supports most of the functions available in
dedicated PLCs.  PLC functions are defined in ladder
diagrams.  In the GX Tool, the PLC is subdivided into eight
pages, PLC1 to PLC8; each is represented by a separate
ladder diagram and a separate module block on the screen.
Table 13 lists common instructions for building a ladder
diagram.

Table 13:  PLC Instructions
Module Instructions
NOP No operation.
LOAD Loads the value of the addressed logic variable into

the result status.
LOAD NOT Loads the inverted value of the addressed logic

variable into the result status.
AND Logical AND between the value of the addressed

logic variable and the result status.
AND NOT Logical AND between the inverted value of the

addressed logic variable and the result status.
OR Logical OR between the value of the addressed logic

variable and the result status.
OR NOT Logical OR between the inverted value of the

addressed logic variable and the result status.
ANDB Logical AND operation between two blocks.
ORB Logical OR operation between two blocks.
OUT Transfers the result status to the addressed logic

variable.
OUT NOT Transfers the inverted result status to the addressed

logic variable.
COS Change-of-state of the result status set the result

status to “1” for one program cycle.
SET Sets the addressed logic variable to the logical “1” if

the result status is “1.”
RST
(RESET)

Resets the addressed logic variable to the logical “0”
if the result status is “1.”

RSR
(RESTART)

Marks the place in the graphic ladder diagram for
the restart of the program cycle when there has
been no power failure or processor reset.  (Location
of RSR is given in END instruction in program code.)

Defining PLC
Modules
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To add a PLC module block:
1. Click on the Add PM button  on the tool bar, or select

Add PM from the Edit menu.
2. Select PLC from the Add PM menu.
3. Place the PLC module block on the screen by dragging it

to the appropriate position, then click once to anchor it.

To add instructions to the ladder diagram:
1. Double-click on the PLC module block.  The following

screen appears.

GX9100 - [Untitled - PLC1]
File Edit View Action Controller Window DX LCD Display Help

Logic Module.Ladder Diagram - PLC1
User Name:
Description:

11:05:30 Friday, October 3, 1997

Figure 52:  Initial Ladder Diagram

The diagram has eight rows.  Each row has eight dots
called “hot points.”  Double-clicking on the control box
in the corner allows you to leave the diagram.  Upon
leaving the diagram, you are prompted to save changes if
you have not done so.

2. Click on the hot point at the top left.  The following
dialog box appears.

Add the PLC
Module Block

Add
Instructions to
the Ladder
Diagram

The top of diagram is
numbered (PLC1-
PLC8).

The User Name and
Description fields can
only be changed
from the PLC block’s
data window.
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GX9100 - [Untitled - PLC1]
File Edit View Action Controller Window DX LCD Display Help

Logic Module.Ladder Diagram - PLC1
User Name:
Description:

11:05:30 Friday, October 3, 1997

PLC List Box

Cancel

OK

 LOAD NOT
 LOAD
NOP

Delete

Figure 53:  Selecting the First Hot Point

You can select LOAD or LOAD NOT as the first
instruction.  If you select LOAD and click on OK, the
following screen appears.

GX9100 - [Untitled - PLC1]
File Edit View Action Controller Window DX LCD Display Help

Logic Module.Ladder Diagram - PLC1
User Name:
Description:

11:05:30 Friday, October 3, 1997

L

Figure 54:  Adding the LOAD Symbol

Note: If you select LOAD NOT, the symbol will look like
the LOAD symbol with a slash through the L.
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The first element of subsequent rows or rows on
subsequent pages may also be the RSR (Restart)
instruction.  The RSR instruction marks the place in the
PLC program where execution will begin as long as
there has been no power failure to the DX-9100
Controller.
All rows and pages before the RSR instruction will only
be executed when the DX-9100 Controller is powered
up after a power failure.  This feature allows the creation
of a “power-up routine” starting in Row 1 of Page 1 and
ending in the row before the RSR instruction.
Only one RSR instruction may be defined, and if no
RSR instruction is defined, the PLC program will always
begin at Row 1 on Page 1.

Note: It is not possible to select a hot point preceded by a
blank column or if the row above the point is empty.

3. Continue to click on unused hot points and add
instructions to the ladder diagram until you have
completed your PLC program.  The ladder diagram
should look something like the following example.

GX9100 - [Untitled - PLC1]
File Edit View Action Controller Window DX LCD Display Help

11:05:30 Friday, October 3, 1997

Logic Module.Ladder Diagram - PLC1
User Name:
Description:

L

L

Figure 55:  Example of a PLC Ladder Diagram
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To create a logic block within a line, select LOAD or LOAD
NOT to begin the block and ANDB to end the block.  The
letter B marks the end of the block.

GX9100 - [Untitled - PLC1]
File Edit View Action Controller Window DX LCD Display Help

11:05:30 Friday, October 3, 1997

Logic Module.Ladder Diagram - PLC1
User Name:
Description:

B
L

L

L

L

Figure 56:  Example of a Logic Block Within a Line

To create OR loops within logic blocks, select ORB and
then LOAD or LOAD NOT.  The OR block will begin at the
LOAD or LOAD NOT instruction of the currently open
logic block and end at the point where the ORB was entered.
The block will automatically be completed with NOP
instructions, which may subsequently be changed to AND
instruction.  In Figure 56, which shows an example of a
logic block within a line, the elements in the second row
form OR blocks.

Creating Logic
Blocks
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To assign an associated logic variable to each instruction:
1. Click on the center of the first PLC instruction.  The

intermediate menu showing all configured modules
appears.  It should look much like the following figure.

GX9100 - [Untitled - PLC1]
File Edit View Action Controller Window DX LCD Display Help

11:05:30 Friday, October 3, 1997

Logic Module.Ladder Diagram - PLC1
User Name:
Description:

L

L

PLC List Box

Cancel

OK

 LRS1-32
 DCO
 TS
DX/XT I/O

 SUPERV
 CLOCK

Delete

Figure 57:  Intermediate Menu for Associated
Variables

Note: An option is provided to DELETE an element, but
this is only allowed for AND, and AND NOT
instructions, because for all other instructions a
change in the graphic representation would be
necessary.

2. Select a module from the intermediate menu and click on
OK.  For example, if you selected TS from the menu
shown in Figure 57, the following figure would appear.

Add
Associated
Logic
Variables to
Instructions
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GX9100 - [Untitled - PLC1]
File Edit View Action Controller Window DX LCD Display Help

11:05:30 Friday, October 3, 1997

Logic Module.Ladder Diagram - PLC1
User Name:
Description:

L

L
PLC List Box

Cancel

OK
 TS1OUT
TS1EXS

Delete

Figure 58:  All Logic Variables Under TS

3. Select one of the logic variables and click on OK.  If you
had selected TS1OUT from the screen shown above, the
ladder diagram would look like the following figure.

GX9100 - [Untitled - PLC1]
File Edit View Action Controller Window DX LCD Display Help

11:05:30 Friday, October 3, 1997

Logic Module.Ladder Diagram - PLC1
User Name:
Description:

L

L

TS1OUT

Figure 59:  LOAD Symbol with Associated Variable
TS1OUT
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4. Continue to add associated variables to the remaining
logic instructions.  When you are finished, your diagram
should look something like the following figure.

GX9100 - [Untitled - PLC1]
File Edit View Action Controller Window DX LCD Display Help

11:05:30 Friday, October 3, 1997

Logic Module.Ladder Diagram - PLC1
User Name:
Description:

L

L

LRS1SSATS1OUT

SSADCO1

Figure 60:  Ladder Diagram with PLC Instructions
and Associated Variables

To save and exit the PLC diagram:
1. Click on the Save button  on the tool bar, or select

Save from the File menu, to save the current session in
the DX configuration.

2. Double-click on the control box  in the upper left
corner of the window (or at the left of the menu bar if
the window is maximized), or click on the close box 
in the upper right corner of the window (or at the right of
the menu bar if the window is maximized), to leave the
PLC ladder diagram and return to the main configuration
window.

Saving and
Exiting the
PLC Diagram
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This section describes how to make and remove logical
connections between the source and destination points of the
various modules.

You can make connections in three ways:  drag the cursor
from one connection point to another, use the Connect
option, or enter the source point within a data window.

Using the Click-Drag Option
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Double-click on both modules
to maximize them.

Place the bent arrow cursor
on the source point.

Click and hold the left mouse
button and drag the bent arrow
to the destination point.

Release the left mouse button.

Click "Yes" or "No"
to choose whether you wa
an inverted connection
(digital inputs only).

The connection appears as
a line between the two modules.

Figure 61:  Using the Click-Drag Method to Make
Connections

Connecting
and Discon-
necting
Modules

Connecting
Modules

want
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Using the Connect Option
To use the Connect option:
1. Use the left mouse button to click on the module that

contains the source point.
2. Click the right mouse button outside of the highlighted

module.  The pop-up module menu will appear.  Select
Connect from the module menu,
or select Connect from the Edit menu,
or press F5.
The Module Connection Dialog Box appears containing
source points for the selected module.

Connect

Cancel

OK
 DIC4
DI4

Figure 62:  Module Connection Dialog Box

3. Choose a source point, then click on OK.
4. Click on the destination module with the left mouse

button.
5. Click outside the module with the right mouse button.

The pop-up module menu will appear.  Select Connect
from the module menu, or select Connect from the Edit
menu, or press F5.
The module connection dialog box appears containing
destination points for the selected module.

Connect

Cancel

OK

 DEC@
 INC@
 ENL@
 AOF@
AO@

Figure 63:  Destination Point Dialog Box
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6. Choose a destination point, then click on OK.  If
applicable, a dialog box appears asking if you want an
inverted connection (Figure 64).

Untitled

Yes No

Is the connection inverted?

Figure 64:  Inverted Connection Dialog Box

7. Click on Yes or No.  A line appears showing the
connection between the two modules.

GX9100 - Untitled

11:05:30 Friday, October 3, 1997

File Edit View Action Controller Window DX LCD Display Help

AI2
AI3
AI4
AI5
AI6
AI7
AI8

AI1

DI1
DI2
DI3

DI5
DI6
DI7
DI8

AO1
AO2
AO9

AO10
AO11

AO13
AO14
DO3
DO4
DO5
DO6
DO7
DO8

DI
DIC

DI4

AO12

OUH
AOH
AOL

AOF@
ENL@
INC@
DEC@

AOF
AO@

OUT

Figure 65:  Example--Connected Modules

Note: Once a destination point has been used, it will not
appear in the destination point dialog box and new
source points will not be able to connect to it.  The
only way to connect a new source point is to delete
the old connection, then define a new one.
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Making Connections Within a Data Window
To make a connection within a data window:
1. Use the left mouse button to click on the module that

contains the destination point.
2. Click the right mouse button outside of the highlighted

module.  The pop-up module menu appears.
3. Select Data from the module menu,or select Data from

the Edit menu.
The Module Data Window appears.

PID (PID1) - Data

User Name

Description
Cancel

OK

Output-Tag...

Input-Tag...

Remote Setpoint -->

Reference Variable -->

Proportional Band -->

OFF Mode Control --> /DI1
Standby Control -->

Reverse Action -->ExtForce Out Level 0.

Ena Startup: 0=N 0
Startup Out Level 100.
Ena Symm Mode: 0=N 0

Ena Shutoff: 0=N 0
Shutoff Out Level 0.

Ena PID to P: 0=N 0
Remote Mode: 0=N 0

Ena Off Trans: 0=N 0

Process Variable -->

External Forcing --> DI1
Output Bias -->

Minimum WSP -->

Maximum WSP -->

Data-2...

Figure 66:  Example Module Data Window

4. Select the data field (box) in the Module Data Window
where you wish the connection.  The blinking cursor
appears in the box.

Note: Only descriptions followed by an arrow (-->) accept
connection information.
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5. Type an asterisk (*) in the box.  A menu appears, listing
the valid configuration modules for the selected field.

PID (PID1)

Cancel

OK

 PM3PSYCHRO
 PM2TOTAL
 DX/XT I/O

Delete

Figure 67:  List of Valid Configuration Modules

6. Select one of the valid configuration modules listed by
double-clicking on it or by highlighting it and selecting
OK.  A menu of all valid outputs belonging to that
module appears.

PID (PID1)

Cancel

OK

 PM2TOT4
 PM2TOT3
 PM2TOT2
 PM2TOT1

 PM2TOT6
 PM2TOT5

 PM2TOT8
 PM2TOT7

Delete

Figure 68:  Valid Outputs

7. Select one of the outputs listed by double-clicking on it
or by highlighting it and selecting OK.

8. If a logic output is selected, a dialog box appears and
asks if you want an inverted connection.  Answer
appropriately.  You are returned to the data window.

9. The name appears in the edit box.  A line appears
showing the connection between the two modules after
exiting the data window.
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To remove a block’s current connection, either use the
“scissors cursor” to “cut” the connection line at the
destination block, choose the Disconnect option, or delete
the connection in the data window.

Using the Scissors Cursor
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Place the cursor at the
point where it turns into the 
scissors cursor.

Click the left mouse button.

Click on "Yes" to confirm that you  
want to delete the connection.

The connection is removed.

Untitled

Are you sure you want to DELETE this connection?

Yes No

Figure 69:  Removing the Connection Using the “Scissors Cursor”

Disconnecting
Modules
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Using the Disconnect Option
To disconnect the modules using the Disconnect option:
1. Click on the destination module with the left mouse

button.
2. Click outside the module with the right mouse button.

The pop-up module menu will appear.
3. Select Disconnect from the module menu, or select

Disconnect from the Edit menu, or press F4.
The Disconnect Dialog Box appears showing all of the
destination points from the selected module that are
currently connected.

Disconnect

Cancel

OK ENL@

Figure 70:  Destination Point Dialog Box

4. Choose the destination point you wish to disconnect,
then click on OK.  A dialog box appears confirming that
you want to delete the connection.

Are you sure you want to DELETE this connection?

Yes No

Untitled

Figure 71:  Delete Confirmation Dialog Box

5. Click on Yes to confirm the deletion.  The connection
line is removed from the screen.
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Using the Data Window
To disconnect the modules using the data window:
1. Using the left mouse button, click on the module that

contains the connection.
2. Click the right mouse button outside of the highlighted

module.  The pop-up module menu appears. Select Data
from the module menu,

      or select Data from the Edit menu.
The Module Data Window appears.

3. Select (highlight) the entire name in the data field (box)
that you want to delete, then press the Delete key, or
select the data field (box) with the connection that you
wish to delete, then press the asterisk (*) key.
A menu appears, listing the valid configuration modules
for the selected field.  Select the Delete button.
You return to the data window.  Press Enter or select the
OK button.
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There are three ways to show the module connections in
detail:
1. Double-clicking on connected modules reveals all the

source and destination points of that module.  Lines will
appear between all connected source and destination
points.

2. Under the data option of the module menu, a data
window appears which contains the data for all the
destination points and parameters of a module.

3. Selecting Show Connections in the View menu will
bring up a dialog box showing all source point
connections for the selected module.

Connections

OK

PID1 has the following output connections:
WSP - AO@(AO14)
WSP - AO@(AO14)
WSP - AO@(AO14)

PID1 has no PLC connections

Figure 72:  Dialog Box Showing Connections

The Trend Log module provides 12 trend log channels, each
recording data from either one analog item or from a set of
eight logic variables (logic variable byte).  The trend can be
used to provide data for Metasys Point History in DX
controllers that are connected remotely (i.e., via dial-up) to
the Metasys system, or for a local DX LCD Display.

When the DX controller is connected to a Metasys system
by an NDM dialer and telephone lines, the trend data may be
read whenever a connection is made by the Metasys system.
The data is stored in the point history file of AI, AOS and BI
objects when they are mapped to the items being recorded.
When the Metasys Point History option is selected for a
trend log channel, only those items which can be mapped to
Metasys objects are allowed and the trend parameters are set
by the GX Tool to default values for the Point History
feature in Metasys.

Showing
Connections

Defining the
Trend Log
Module

Metasys Point
History (for DX
Versions 1.4
and 2.3 or
later)
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You must link the Historical Trend Read Request (HTRR)
logic variable to the DIAL request logic variable in a PLC
module to initiate a dial-up connection when a trend record
buffer is full.  Since a DX Version 3.x cannot be connected
to a Metasys system by the NDM dialer and telephone lines,
trend logs cannot be configured for Metasys Point History in
these versions.

Trend channels that are not used for Metasys Point History
are freely configurable.  For analog items the sampling rate
may be entered and the stored values may be either the
average, maximum, or minimum values during the period, or
the instantaneous value at the time of reading.  Logic
variables are recorded with a time and date stamp when
there is a change of value.  All channels may be displayed
on the DX LCD Display.

To add the Trend Log module to the configuration:
1. Click on the Add PM button  on the tool bar, or select

Add PM from the Edit menu.
2. Select Trend from the Add PM menu.
3. Place the Trend Log module block on the screen by

dragging it to the appropriate position, then click once to
anchor it.  You can move the module at any time by
clicking and dragging it to a new position on the screen.

To define the Trend Log module channels:
1. Double-click on the Trend Log module block.  The

Trend Log Data window opens, as shown in Figure 73:

Configuration
for DX LCD
Display (for DX
Versions 2.3
and 3.3 or
later)

Adding the
Trend Log
Module Block

Defining the
Trend Log
Channels
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File Edit Window Help

11:05:30 Friday, October 3, 1997

Trend Log Data

No. Meta.P.H Item Sample Mode Sample Rate Synch. Read Req.
1 No AI1 Average 120 Min Day 48
2 Yes AI2 Actual 30 Min Hour 48
3 Yes DI1..8 Logic Variables -- - 10
4 No XT1DI1..8 Logic Variables -- - 30
5
6
7
8
9

10
11
12

GX9100 - [Untitled- Trend Data]

Figure 73:  Trend Log Data Window

The table has 12 rows, each defining a channel.
2. Click with the right mouse button on the channel you

want to configure and select Data from the pop-up menu
that appears, or highlight the channel, then select Data
from the Edit menu.  The Data dialog box for the Trend
Log channel appears, as shown in Figure 74:

Data

Tag Name

Enter the Tag Name or * to select.

Cancel

OK*

Metasys Point History

Figure 74:  Data Dialog Box for Trend Log Channel

Note: Metasys Point History is grayed and unavailable for a
Version 3.x DX controller because it cannot be
monitored remotely with an NDM dialer.

3. Check the Metasys Point History box if required, then
enter the desired Tag Name of the item to be recorded.
Use an asterisk (*) for the Tag Name to select the item
from a list of valid tag names.  Click OK to continue to
the next dialog box, which depends on what you entered
for the Tag Name, as follows:
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• If you entered a specific tag name (e.g., AI1), the next
dialog box is the appropriate Trend Data dialog box
for the selected item.  Skip to Step 7 in this procedure,
which describes the Trend Data dialog boxes.

• If you entered an asterisk (*), then a series of dialog
boxes appear that allow you to select from item
categories and sub-categories until you find the
individual item that you want to add.  Continue with
the next step (Step 4) in this procedure.

4. If you entered an asterisk (*) in the Tag Name field of
the Data dialog box (Figure 74), then a dialog box
showing item categories appears, as shown in Figure 75:

Select

Cancel

OK

Internal Points
Programmable Modules
DX Input/Output

Figure 75:  Select Item Category Dialog Box

Note: The categories and items shown in the series of dialog
boxes depend on the controller version and whether
you selected Metasys Point History.

5. Select a category by double clicking on it, or by clicking
on it to highlight it and then clicking OK.  Another
dialog box appears listing sub-categories of the category
you chose in the previous dialog box.  For example, if
you chose DX Input/Output in Figure 75, the dialog box
shown in Figure 76 appears:

Select

Cancel

OK

DO Analog Source 3-8
Analog Output 1-2
Digital Input 1-8
Analog Input 1-8

XTn Analog Input 1-8
Digital Output 3..8

Analog Output 9-14
XTn Digital Output 1..8
XTn Digital Input 1..8
XTn Analog Output 1-8

Figure 76:  Select Sub-category Dialog Box
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6. Select a sub-category by double clicking on it, or by
clicking on it to highlight it and then clicking OK.
Another dialog box appears listing either additional
sub-categories or individual items.  For example, if you
chose Analog Input 1-8 in Figure 76, a dialog box listing
individual points appears, as shown in Figure 77 below:

Select

Cancel

OK

AI4
AI3
AI2
AI1

AI6
AI5

AI8
AI7

Figure 77:  Select Item Dialog Box

Note: There may be several dialog boxes listing
sub-categories before you reach the dialog box listing
individual items (similar to the one shown in
Figure 77).  Simply repeat Step 6 until you find the
item you want to add to the table.  Refer to
Appendix 3: Trend Log Items for a list of the tag
names available in Trend Log.

7. Select the item you want to add to the table by double
clicking on it, or by clicking on it to highlight it and then
clicking OK.  One of two Trend Data dialog boxes
appears, depending on whether you selected an analog
item (Figure 79) or logic variable set (Figure 80).

Note: When selecting a logic variable, choose the byte that
contains the required variable.  All variables in the set
are then available for Metasys Point History or for the
DX LCD Display.  Since a logic variable set is
recorded when any one of its variables changes state,
it is recommended that you assign LRS logic variable
bytes to the trend log and then connect the source
variables (the ones that you wish to trend) to the LRS
variables in a PLC module.

For example, if you want to trend TS1OUT, DO1, DO2,
BI1, BI2, LRS18, LRS19 and LRS20, the following PLC
logic would set LRS1–LRS8 with the values you want to
trend.
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( )
LRS1

DO1
( )

( )

( )

( )

( )

( )

( )

Ts1out1

LRS2

LRS3

LRS4

LRS5

LRS6

LRS7

LRS8

DO2

BI1

BI2

LRS18

LRS19

LRS20

Example

Figure 78:  Trend Example

Trend Data

CancelOK

Tag AI1

Sampling Rate Min 30

SamplesRead Request 48

Sampling Mode Actual Synchronization Hour

Figure 79:  Trend Data Dialog Box for an Analog
Item

Trend Data

Cancel

OKTag --> DI1..8

 10 SamplesRead Request

Figure 80:  Trend Data Dialog Box for a Logic
Variable Set
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8. Enter the desired values in the data fields or select from
the drop-down list boxes.  Table 14 describes the fields,
their possible values, and their default values.

Table 14:  Trend Data Entries and Options
Dialog Field Possible Values Default (= Metasys  Point

History Setting)
Sampling Rate*
(period of time
between records)

5, 10, 15, 20, 60 Sec**
1 to 1440 Min

Analog Input: 30
Analog Output: 30

Units for Sampling
Rate

Sec (seconds)
Min (minutes)

Min

Read Request***
(number of new
samples to set HTRR)

Analog: 0 to 61
Logic Variables: 0 to 30

Analog Input: 48
Analog Output: 48
Logic Variables: 10

Sampling Mode
(analog value to
record at end of each
period)

Actual
Average
Maximum
Minimum

Actual

Synchronization
(exact time of the
start of trend
recording)

None
Day (midnight 00:00:00)
Hour (xx:00:00)
Minute (xx:xx:00)

Hour

Note *: Logic Variable bytes are read each second, but only recorded when there has
been a change of state in at least one bit.

Note **: When seconds are selected, the GX Tool automatically increases the entered
value to one of the specified values, and gives an error if the value is over 60.

Note ***: A Read Request value of 0 disables the Read Request feature for the Item or
Logic Variable.

Note: If  Metasys Point History was checked, the GX Tool
sets the trend parameters to appropriate default values
and these values cannot be changed.

9. Click on OK to save the channel data and return to the
Trend Log definition table.
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To save the Trend Log definitions and exit the Trend Log
Data window:
1. Click on the Save button  in the tool bar, or select

Save from the File menu, to save the current session in
the DX configuration.

2. Double-click on the control box  in the upper left
corner of the window (or at the left of the menu bar if
the window is maximized), or click on the close box 
in the upper right corner of the window (or at the right of
the menu bar if the window is maximized), to close the
Trend Log Data window and return to the main
configuration window.

In any free line of a PLC module, add a LOAD element
assigned to the logic variable HTRR (listed under
DIAGNOSTIC), followed by a COS instruction and a SET
element assigned to the logic variable DIAL (listed under
SUPERV).  If other logic variables have already been
configured to set the DIAL variable, add the HTRR variable
and the COS instruction as an ORB element (OR block) to
the ladder diagram.  An example is shown in Figure 81:

GX9100 - [Untitled - PLC1]
File Edit View Action Controller Window DX LCD Display Help

11:05:30 Friday, October 3, 1997

Logic Module.Ladder Diagram - PLC1
User Name: DIAL

Description: Dial Control

DIAL
L

DI1
COS SET

L
DI2

COS

L
HTRR

COS

Figure 81:  Ladder Logic to Set DIAL from Trend
Log

Saving and
Exiting the
Trend Log
Definition

Configuring
the DIAL
Function for
Metasys Point
History
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To save a GX-9100 configuration:
1. Click on the Save button  in the tool bar, or select

Save from the File menu.  The configuration will be
saved under the current file name.

Note: If you save a configuration while in Show Selected
mode, the entire configuration will be saved.
However, the next time you open the saved file, you
will only see the selected view.  To see the entire
configuration, select Show All from the View menu.

If you are saving the configuration for the first time, the
following window appears.

File Save As

Folders:

c:\gx9100

c:\
Cancel

OK

Drives:

Network...gx9100

File name:

config1.dxs
config2.dxs
timesup.dxs
bldg3fl2.dxs

List files of type:

GX9100 Files (*.dxs) c:

 untitled.dxs

Figure 82:  File Save As Window

To save a GX-9100 configuration under a different file
name, select Save As from the File menu.  Type in the new
file name, and click on OK.  The configuration will be saved
under the new name.

Saving the
Configuration
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To download the configuration to the DX controller:
1. Select Download from the Action menu.  The following

dialog box appears.
Download

Cancel

OKItem

DX and XT/XTM

DX, XT/XTM and Network

Port

File

COM2

COM1DX

XT/XTM

Network

Calibration

Time

Address 0 DX Password 0000

Figure 83:  Download Dialog Box

2. Select the item you want to download and the port you
want to use for the download by clicking on the radio
buttons.

Note: If downloading from the OWS, the item selected must
be DX, XT/XTM and Network or DX and XT/XTM,
and the port selected must be File. This creates a file
with a .DXF extension.  Next, move the file from the
GX-9100 directory to the Metasys directory under the
System91 subdirectory.  Then it can be downloaded
from a DX-9100 Device Object Focus window in the
OWS.

3. Enter the address of the controller to download the
configuration to in the Address data field.  The address
must be a number between 1 and 255.  If you selected
XT/XTM as the item to be downloaded, no address is
required (it is already stored in the configuration), and
the Address field is grayed and unavailable.

Note: Address 255 is reserved for the DX LCD Display with
N2 Bus operation. Select another address if there is a
DX LCD Display on the N2 Bus of the controller
selected. If 255 is entered, the following dialog box
appears:

Downloading
to a DX
Controller
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Figure 84:  Address Warning Dialog Box

4. Only for DX Versions 1.4, 2.3, 3.3, or later:  If the DX
controller already has a configuration with a password,
enter the number in the DX Password field.  Otherwise,
enter or leave the number at 0.  The download fails if the
password number is incorrect.

Note: If the password in the configuration being
downloaded is different from the password in the
controller, the password is changed in the controller.
Also, the DX Password field only appears if the
password protection feature is enabled in the
GX9100.INI file (see Enabling Password Protection
for the DX-9100 Download/Upload Dialogs under
Software Installation at the beginning of this guide).

5. Click on OK.  The hourglass appears on the screen until
the configuration has downloaded.

If your configuration is very complex, for clarity you may
want to view only certain points and modules.  To do this:
1. Select the points and modules you want to view by

clicking on them while holding down the Ctrl key.  (This
allows you to select more than one point or module at a
time.)

2. Select Show Selected from the View menu.

Viewing
Configura-
tions

Show Selected

GX9100

Select an address other than 255 if there is a DX LCD Display on the N2 Bus of this controller. Continue?

NoYes

gxadwarn
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3. To see all points and modules on the screen, select Show
All from the View menu.

The Trace feature makes all lines (connections) invisible
except those connected to a selected module.  This allows
you to easily trace a path without other connections in the
way.
The following figure shows how the screen will look before
using the Trace feature.

GX9100 - Untitled

11:05:30 Friday, October 3, 1997

File Edit View Action Controller Window DX LCD Display Help

AI2
AI3
AI4
AI5
AI6
AI7
AI8

AI1

DI1
DI2
DI3
DI4
DI5
DI6
DI7
DI8

AO1
AO2
AO9
AO10
AO11
AO12
AO13
AO14
DO3
DO4
DO5
DO6
DO7
DO8

8-CALC1

PID2

BIN-SEQ3

TOTAL4

AC0 DC0

XT3

PLC1 PLC2 PLC3 PLC4

PLC5 PLC6 PLC7 PLC8

LRS1-32 LRS33-64 EXD OSI

COMPRTR5

Figure 85:  Before Trace Example

Follow these steps to trace the connections for the PID2
module:
1. First select the module that you wish to trace by clicking

on it.
2. Select Trace from the View pull-down menu.  All

connections become invisible except for the connections
of the selected module.  The connections for that module
remain visible for easy tracing.

Trace



84     Configuration Tools—GX-9100 User’s Guide

GX9100 - Untitled

11:05:30 Friday, October 3, 1997

File Edit View Action Controller Window DX LCD Display Help

AI2
AI3
AI4
AI5
AI6
AI7
AI8

AI1

DI1
DI2
DI3
DI4
DI5
DI6
DI7
DI8

AO1
AO2
AO9
AO10
AO11
AO12
AO13
AO14
DO3
DO4
DO5
DO6
DO7
DO8

8-CALC1 COMPRTR5

PID2

BIN-SEQ3

TOTAL4

AC0 DC0

XT3

PLC1 PLC2 PLC3 PLC4

PLC5 PLC6 PLC7 PLC8

LRS1-32 LRS33-64 EXD OSI

Figure 86:  Module Selected for Easy Tracing

3. To trace the connections path for another module,
simply click on another module.  To trace multiple
modules at the same time, use Ctrl-click on each
subsequent module.

4. To turn off the Trace function, simply select Trace from
the View pull-down menu again.

If you have defined user names for the configuration, you
may want to view those names rather than the predefined
point and module tags.  To do this, select Show User Names
from the View menu.  To return to viewing point and
module tags, select Show Tag Names from the View menu.

Show User
Names
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To set up headers and footers for printing configurations:
1. Select Header/Footer from the File menu.  The

Header/Footer dialog box appears.
Header/Footer Dialog

Cancel

OK
Header

Page Options

Company Name

Johnson Controls

Top Left

Job Name

Top Middle

Controller

Top Right

Page

Branch Engineer Created on

Only First PageEvery Page

Footer

Bottom Left

Printed on

Bottom Middle

Filename

Bottom Right

Branch

Figure 87:  Header/Footer Dialog Box

2. Fill in the Company Name edit box.
3. Select the desired field positions for the header and

footer using the drop-down lists.  The information for
Job Name, Controller Name, Engineer, Branch, and
Created on is entered in the Job Information screen.
Refer to Defining Job Information in this document.

Printing
Configura-
tions

Setting Up
Header and
Footer Options



86     Configuration Tools—GX-9100 User’s Guide

4. An example of the header and footer styles is shown
below.
Note that a new configuration has default settings.  The
default Company Name is Johnson Controls.  The
default position for each header/footer field is shown in
the example below.
The header includes descriptors, like JOB NAME:, but
the footer does not.

Johnson Controls

JOB NAME:  Test Job
Branch:  JC Toronto

Controller Name:   DX123987
Engineer:   H.W.Schillack Created on: 95/05/09

Page: 1

Tuesday, May 9, 1995 DX123987.DXS JC Toronto

Header Example:

Footer Example:

Figure 88:  Header and Footer Example

5. Select whether the header should appear on every page
or only the first page by selecting the appropriate radio
button (Figure 87).

6. Select OK if you are satisfied with the format, or Cancel
to revert to the default settings.
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To view how the configuration will look when printed:
1. Select Print Preview from the File menu.  The following

dialog box appears.
Print Items

Cancel

OK
All Items

Selection

Graphical Selection

Items (Listed below)

Draft

Print Format

Final

Data

Data Selection

Input Tags

Output Tags

Layout

Items

PMs

Inputs

Outputs

Network Inputs OST PLC Code DX LCD Display

TS PLC Global

XT Labels EXD Calibration

XTs DCO INFO

Network Outputs ACO LABELS

Trend

Figure 89:  Print Options Dialog Box

2. Select the options you want to preview by clicking on
the radio buttons and check boxes.  Table 15 describes
some of the options in this dialog box.

Table 15:  Print Options
Option Description
Selection (You may select only one of the following.)
All Items Prints all items listed in the Items box, including module data,

job information, calibration information, and global data.
Graphic Selection Prints all items selected in the configuration layout.
Items (Listed below) Prints all items with checked boxes in the Items box.
Print Format (You may select only one of the following.)
Draft Prints the configuration as it would be printed in draft mode

(without page headers and footers).
Final Prints the configuration as it would be printed in final mode (with

page headers and footers).
Data Selection (You may select more than one of the following.)
Data Includes data for every module with the configuration printout.
Input Tags Includes a list of defined input-tags for every module with the

configuration printout.
Output Tags Includes a list of defined output-tags for every module with the

configuration printout.

Previewing the
Printed
Configuration
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3. Click on OK.  A screen similar to the following appears.

11:05:30 Friday, February 7, 1997

Print... Next Page Prev PagePrev Page Zoom In Zoom OutZoom OutTwo Page Close

GX9100 - [Untitled]

AI1

AI2

AI3

AI4

AI5

AI6

AI7

AI8

DI2

DI3

DI4

DI5

DI6

DI7

DI8

DI1

JOB NAME: xxxx
CONTROLLER: xxxx

JOHNSON CONTROLS
BRANCH: xxxx
      DATE: yy/mm/dd

AO1

AO2

AO9

AO10

AO11

AO12

AO13

AO14

DO4

DO

OUH

DO@

DO6

DO7

DO8

DO3

WEDNESDAY, AUGUST 03, 1994 PAGE 1UNTITLED

DO5

ENGINEER: xxxx
 FILENAME  xxxx

Figure 90:  Print Preview

4. The page on the screen looks exactly like the printed
document.  You can zoom in to view half- and quarter-
page views by clicking on the Zoom In button.  Click on
the Zoom Out button until you return to the full page
view.  To view two pages at a time, click on the Two
Pages Button.  To return to the one-page view, click on
One Page.  To view pages not displayed on the screen,
click on Next Page or Prev Page.

5. If you decide you do not want to print the configuration
at this time, click on Close.
If you decide to print the document, click on Print.  This
will bring you to Step 3 in the regular print sequence
described below.
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To print a configuration:
1. Click on the Print button  on the tool bar, or select

Print from the File menu.  The following dialog box
appears:

Print Items

Cancel

OK
All Items

Selection

Graphical Selection

Items (Listed below)

Draft

Print Format

Final

Data

Data Selection

Input Tags

Output Tags

Layout

Items

PMs

Inputs

Outputs

Network Inputs OST PLC Code DX LCD Display

TS PLC Global

XT Labels EXD Calibration

XTs DCO INFO

Network Outputs ACO LABELS

Trend

Figure 91:  Print Options Dialog Box

2. Select the print options you want and click on OK (Table
15).  The following dialog box appears.

Print

Cancel

OKPrinter: Default Printer (HP LaserJet 4/4M
Post on LPT1:)

Collate Copies

From:

Setup...

Print Range

All

SelectionSelection

Pages

To:

Copies:

1

1Print Quality: 600 dpi

Figure 92:  Print Dialog Box

Print
Sequence
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3. Choose the print range by clicking on one of the radio
buttons.  Note that if you choose Page, you also need to
enter the starting and ending page numbers in the From:
and To: data fields.

4. Select the print quality from the drop-down list.  A
higher DPI (Dots Per Inch) number equals a better, but
slower, printed copy.

5. Enter the number of copies you want in the Copies: data
field.  If you’re printing more than one copy, and you
want each set of pages to print out in order, check the
Collate Copies box.

6. If you need to change printer options, click on the Setup
button.  Otherwise, click on OK to print your
configuration.

The tag name file allows the user to create an ASCII text file
for the current GX Tool configuration file.  This file can be
modified offline using any text editor, and read back into
any configuration file.  The information contained in the tag
file is job information, user name, description, and input and
output tags for each defined input, output, and program
module.  In situations where multiple similar controller
applications exist, it reduces the amount of repetitive typing
by modifying and reusing a single file.  To do this, use the
Read User Names and Write User Names menu options in
the File pull-down menu as follows:

Once you have defined a configuration, all tags, and user-
defined names, create an ASCII (text) file containing all tags
and user names for that configuration:
1. While in the configuration from which you want to make

the tag file, select Write User Names from the File pull-
down menu.  A Tag Name Dialog Box appears similar to
the one below.

Creating Tag
Name ASCII
Files

Write User
Names
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Figure 93:  Tag Name Dialog Box
(Write User Names)

2. Replace the asterisk (*) in the File Name box with the
name you wish to give the .tag file.

3. Use standard Windows methods to select the drive and
directory where you wish to place the file.
The Network button only appears if you are on a
network.  If you need to change to a different server,
select the Network button.  The Network - Drive
Connections dialog box appears.  If you need additional
assistance concerning using this screen, consult with
your network administrator.

4. Select OK to save it.

Tag Name Dialog

Folders:

c:\gx9100

c:\
Cancel

OK

Drives:

Network...gx9100

File name:

List files of type:

Tag name files (*.tag) c:

 *.tag

gxtagnm
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5. The new .tag file can now be edited using any text
editor and/or imported into another configuration as
defined under Read User Names below.  A partial
example of a typical .tag file is shown here.
Following the equal signs (=), you can insert user-
defined names.  The names you enter become the User
Names for the appropriate tags in the new configuration.
Project Descriptions are limited to 50 characters per line.
Tag names are limited to 8 characters, and tag
descriptions are limited to 24 characters per line.

[File]
File=A:\AHU601.TAG

[Job Information]
Job Name=507 E. MICHIGAN
Controller Name=AHU-601
Engineer=WARREN JOHNSON
Branch=MILWAUKEE
Project Description1=
.
.
.
Project Description5=

[AI1]
User Name=DA-T
Description=
* Output Tag
AI=da-t
AI%=
AIH=
AIL=
OVR=
UNR=

[AIn]
User Name=RM-T
Description=

[TS1]
User Name=
Description=
* Input Tag
TSOV@=
TSON@=
TSOF@=
* Output Tag
EXS=
OUT=

[TSn]
User Name=
.
.
.
[LRSnn-mm]
User Name=
Description=
* Output Tag
LRSnn=
etc.
.
.
.

typ_tag

Figure 94:  Partial Example of a Typical .TAG File



Configuration Tools—GX-9100 User’s Guide     93

Follow the instructions below to import the Tags and User
Names into a configuration from a .tag file created from
Write User Names:
1. From within the configuration into which you want to

import the tag file, select Read User Names from the
Files pull-down Menu.  A Tag Name Dialog Box
appears similar to the one below.

Tag Name Dialog

Folders:

c:\gx9100

c:\
Cancel

OK

Drives:

Network...gx9100

File name:

tagname1.tag
tagname2.tag
tagname3.tag

List files of type:

Tag name files (*.tag) c:

 *.tag

Figure 95:  Tag Name Dialog Box
(Read User Names)

2. Use standard Windows methods to select the drive and
directory containing the file.
If you need to change servers, select the Network button.
The Network - Drive Connections dialog box appears.

3. Select (highlight) the desired tag file from the list in the
left side box.  Select OK.  The tag and user-defined
names are imported into the open configuration.

Note: The user names change for the matching modules
only.

Read User
Names
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When the configuration is saved, two DDL files are also
created.  One has the extension .DMO and is a DDL Model
File for mapping CS objects.  This file is also used for
Template Commissioning in EUROPRO.  The other file has
an extension of .DNC and is an NC DDL file with the
hardware items AIn, DIn, AOn, and DOn mapped to
appropriate Metasys objects.
To select the items to be included in the DDL files:
1. Select DDL File Options from the File menu.  The

dialog box shown in Figure 96 appears:
DDL File Options

Cancel

OK
Selection

Items Listed Below

All Items

System Name

Generate DDL On File Save

ITEMS

Show only items with user name

System

DX

BO

BI

AO

AI

PM

LRS 33-64

LRS 1-32

ACO

DCO

PM

LRS 33-64

LRS 1-32

ACO

DCO

BO

BI

AO

AI

XT

BO

BI

AO

AI

BO

BI

AO

AI

Network

AI

BIBI

AI

Figure 96:  DDL File Options Dialog Box

2. Select All Items or Items Listed Below by clicking on
the radio buttons.  If you select Items Listed Below, the
items in the ITEMS box are enabled and can be selected.
Select those items that you want to be included in the
DDL files by clicking on their check boxes.  The items
can be further limited by checking the box “Show only
items with user name.”

3. Enter the desired eight character Metasys System Name.
4. By default, the DDL files are generated when you save

the controller configuration.  To disable the generation
of DDL files, click on Generate DDL On File Save to
remove the check mark.

5. Click on OK to save your selection.

Creating DDL
Files
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Modifying Configurations

You can access an existing configuration to modify in two
ways:
1. Upload an existing configuration from the controller.
2. Open a previously saved configuration file.

Note: It is recommended that you save the current
configuration before uploading, as the current
configuration on the screen will be replaced by the
configuration uploaded from the controller.

To upload a configuration from the controller:
1. Select Upload from the Action menu.  The following

dialog box appears.
Note: If upload is selected while PLC windows are open, an

error is shown.  Close all PLC windows associated
with the current configuration and try again.

Figure 97:  Upload Dialog Box

2. Select the item you would like to upload and the port to
which the DX controller is connected by clicking on the
radio buttons.

Uploading a
Configuration
from the
Controller

Upload

Cancel

OKItem

DX

DX and XT/XTM

COM2

COM1

XT/XTM

Calibration

Address 0 DX Password 0000

File

Port

gxupbox

XT/XTM selection is not supported when DX is password
protected - use DX and XT/XTM selection.
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Note: The port selection File may only be used if the GX
Tool is running on a PC with M-Tool software, where
files with the extensions .DXU, .XTU or .CLU are
stored. These files are created when uploading a
configuration from a DX controller via an N30 using
the Loader UI program. DXU files contain DX and
XT/XTM configuration data, XTU files contain
XT/XTM data only, and CLU files contain calibration
data only. Click on OK and the following dialog box
will appear in which you can select a file to upload.

Figure 98:  Upload From File Dialog Box

Select a file. It is not necessary to enter an address or
password. Then proceed to Step 5.

3. Enter the address of the controller you are uploading
from in the Address field.  If you are uploading an
XT/XTM that is directly connected to the N2 Bus (not
connected to the XT Bus of a DX controller), enter the
address of the XT/XTM module.

4. Only for DX Versions 1.4, 2.3, 3.3, or later:  Enter the
password number of the configuration you are uploading
in the DX Password field. The upload fails if the
password number is incorrect.

Note: The DX Password field only appears if the password
protection feature is enabled in the GX9100.INI file
(see Enabling Password Protection for the DX-9100
Download/Upload Dialogs under Software
Installation at the beginning of this document).

Upload From File

Folders:

d:\gx6_0\release\internal

d:\
Cancel

OK

Drives:

gx6_0

File name:

List files of type:

 (*.DXU) d:

release
internal

 *.dxu

gxupfi

Network...

Help
config01.dxu
config02.dxu
bldg4fl1.dxu
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5. Click on OK. Upload first checks whether the
configuration in the tool matches the configuration in the
controller (unless you are uploading a calibration).
Upload DX checks only for DX elements and upload
XT/XTM checks against XT1/XTM1 and its associated
EXPs.  Upload DX and XT/XTM checks both.  If the
check fails, the following dialog box appears:

Config1

Modules do not match.
Upload will overwrite the current configuration
OK to continue?

CancelOK

Figure 99:  Modules Do Not Match Dialog Box

6. Select OK to continue uploading the configuration.  The
configuration will appear on the screen when the upload
is completed.

If you have created and saved configurations before, you can
open the saved files and modify them.  To open a previously
saved file:
1. Click on the Open button  in the tool bar, or select

Open from the File menu.  The following dialog box
appears:

File Open

Folders:

c:\gx9100

c:\
Cancel

OK

Drives:

Network...gx9100

File name:

config1.dxs
config2.dxs
timesup.dxs
bldg3fl2.dxs

List files of type:

GX9100 Files (*.dxs) c:

 *.dxs

Figure 100:  File Open Dialog Box

Opening a
Configuration
File
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2. Select the configuration you want to modify from the
File Name list.
If the configuration you want does not appear in this list,
you can search other directories by clicking on the
folders in the Directories box, and you can access other
drives by selecting them from the Drives drop-down list.

3. When you have selected the correct configuration file,
click on OK to open it.

You can change the configuration of analog inputs and
digital outputs using the following procedure.
1. Click on the AI or DO with the right mouse button to

bring up its pop-up menu.
2. Click on Delete.  The following message box appears.

Are you sure you wish to DELETE this module?

Yes No

Config1

Figure 101:  Delete Confirmation Message Box

3. Click on Yes.  This deletes the current input/output
configuration and removes its double border, but does
not remove the AI or DO from the screen.

4. Click on the AI or DO with the right mouse button again
to bring up its pop-up menu.

5. Click on the new input/output type.  The input/output
will be reconfigured as the new type, and the double
border will appear.

To modify the data associated with inputs and outputs,
follow the same procedure that you used to enter the data.
Call up the data window, enter the new values in the data
fields, and click on OK to save the changes.

Modifying
Inputs and
Outputs

Modifying
Input/Output
Configurations
(AIs and DOs
only)

Modifying
Associated
Data
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You can delete a module using the following procedure:
1. Click on the module with the right mouse button to bring

up its pop-up menu.
2. Click on Delete.  The message box shown in Figure 102

appears.

Are you sure you wish to DELETE this module?

Yes No

Config1

Figure 102:  Delete Confirmation Message Box

3. Click on Yes to delete the selected module or No to
cancel the operation.

To modify the data associated with modules, follow the
same procedure that you used to enter the data.  Call up the
data window, enter the new values in the data fields, and
click on OK to save the changes.  To change the module
type, delete the module and configure a new module.

Modifying Associated Logic Variables
To modify the associated logic variables in a  PLC module’s
ladder diagram:
1. Double-click on the PLC module block to open its

ladder diagram.
2. Double-click in the middle of the instruction block to

modify the associated logic variable.  The intermediate
menu for associated variables will appear.

3. Choose a module from the intermediate menu and click
on OK.  The list of that module’s variables will appear.

4. Choose a variable from the list and click on OK.  The
program will prompt you to confirm the change.

5. Click on Yes to confirm the change.  The new associated
variable will appear above the instruction block.

Deleting
Modules

Modifying
Modules
Modifying
Associated
Data

Modifying PLC
Modules
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Modifying Instruction Blocks
To modify an instruction block:
1. Double-click on the PLC module block to open its

ladder diagram.
2. Double-click on the hot point of the instruction block

you want to modify.  A list of instructions appears.
Note: Only instructions that do not affect the graphic

representation of the ladder diagram can be changed.
Other instructions may only be changed by erasing the
PLC module (Edit--Clear) and re-entering the
instructions.

3. Select a new instruction and click on OK.  The program
will prompt you to confirm the change.

4. Click on Yes to confirm the change.  The new
instruction block will appear in the diagram.  Note that
you will have to re-assign an associated variable.

Erasing the Ladder Diagram
To erase the ladder diagram:
1. Double-click on the PLC module block to open its

ladder diagram.
2. Select Clear from the Edit menu. The diagram will be

cleared.
Note: The program does not prompt you to confirm the clear

command.  Make sure you want to clear the diagram
before executing this command or all data in that
diagram will be lost.  If clear is selected by mistake,
the original diagram can be recovered by closing the
PLC window without saving the changes and then
reopening the window.
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You can edit a module’s number with the following
procedure:
1. Click on the module with the right mouse button to bring

up its pop-up menu.
2. Click on Change Module Number and the dialog box

shown in Figure 103 appears.
Change Module Number

Cancel

OK1

Figure 103:  Change Module Number Dialog Box

3. Select the new module number in the list of available
choices and click OK.  The module appears with the new
number.

Note: When modifying the module number of an XT or
XTM with an attached EXP, both the XT/XTM and
EXP numbers change.  Also, the names of the
associated inputs and outputs change.

To add new connections to an existing configuration, use the
same procedure outlined in the Connecting and
Disconnecting Modules section of this document.

To delete existing connections, use the same procedure
outlined in the Connecting and Disconnecting Modules
section of this document.

To change existing connections, first delete the connection
you want to change, then make the new connection.

Modifying
Module
Numbers

Modifying
Connections

Adding New
Connections

Deleting
Connections

Changing
Connections
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To calibrate analog inputs or outputs:
1. Upload the calibration values following the procedure in

Uploading a Configuration from the Controller section
of this document.  Make sure you click on the radio
button next to Calibration when you do the upload.

2. Select Calibration from the Edit menu.  The following
dialog box appears.

Calibration

CancelOK

Inputs

Clock Daily Adjust 0

LOWHIGH
AD Conversion 16417 3048

Preamplifier 16385 3073

AI1 Pass. Ref. 10368 6912

AI2 Pass. Ref. 10370 6910

AI3 Pass. Ref. 10390 6920

AI4 Pass. Ref. 10380 6916

AI5 Pass. Ref. 10385 6915

AI6 Pass. Ref. 10378 6911

AI7 Pass. Ref. 10380 6912

AI8 Pass. Ref. 10368 6912

Outputs
CURRENTVOLTAGE

LOWHIGH LOWHIGH
AO1 3990 48 3980 48

AO2 3957 48 3983 48

AO9 3980 48 3976 48

AO10 3990 48 3990 48

AO11 3985 47

AO12 3970 45

AO13 3986 50

AO14 3990 48

Figure 104:  Calibration Dialog Box

3. Change the values in the edit fields to adjust the input or
output.

4. Download the calibration values to the controller
following the procedure in Downloading to a DX
Controller.  Make sure you select Calibration when you
do the download.

Note: If you want to save calibration data, you must create a
file for each DX-9100 Controller, as the calibration
data for each controller will be different.

Calibrating
Analog
Inputs and
Outputs
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Downloading and Uploading
a DX Controller via the N30
Controller

To enable this feature, an entry must be made in the
GX9100.INI file. Refer to Software Installation -
Enabling Download and Upload via N30 Controller earlier
in this document. For details of the N30 Supervisory
Controller, refer to the N30 Supervisory Controller
Technical Manual, FAN 689.

To download the configuration to the DX controller via an
N30 Supervisory Controller from a PC with M-Tool
software:
1. Select Download Via N30 in the Action menu. The

following dialog box appears.

Figure 105:  Download Via N30 Dialog Box

2. Select the item you want to download by clicking on the
corresponding radio button.

Note: Version 6.0 of the GX Tool, does not support the
download and upload of the XT/XTM module
configuration via the N30 using items DX and
XT/XTM or XT/XTM. Use a direct connection to the
controller to download and upload these modules.

Downloading

gxn30dwn

Download Via N30

Cancel

OK

Item

DX

DX and XT/XTM

XT/XTM

Calibration

Time

Address 0
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3. In the Address data field, enter the address of the
controller to be downloaded. The address must be a
number between 1 and 255.

Note: A download file will be created for the N30 download
program. Files with DXF extensions contain DX and
XT/XTM configuration data, XTF files contain
XT/XTM configuration data only, and CLF files
contain calibration data only. The DX address will be
used by the N30 download program to locate the
controller on the N2 Bus.

4. Click on OK and the Loader UI program will be
launched.

Note: If the Loader User Interface program
(loaderui.exe) cannot be located, the following
dialog box appears:

Figure 106:  Loader Not Found Dialog Box
gxnotfou

GX9100

Loader UI not found. 
Check the path in GX9100.ini file.

OK
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When the Loader User Interface program has been
successfully launched, the following dialog box appears:

Figure 107:  Loader UI Dialog Box for Download

Note: The File Name is the path name of the open
configuration in the GX-9100 Tool with the extension
DXF, XTF or CLF. It cannot be changed.

5. The default site appears in the Site Name field. To select
a site other than the one displayed, click on the down
arrow in the Site Name field. Only those sites that are
defined in the Site Book, created by M-Tool software,
are shown. Click on the Connect Site button to launch
the Site Manager and establish connection with the
selected site. The Site Manager appears as a task bar
button on the Windows screen task bar. If a site is
already connected and another site is selected, the
following warning appears:

Figure 108: Site Disconnect Warning for Download

File Name:

Loader UI

Site Name:

Supervisory Controller:

Browse...

Download

Upload

Abort

Close

DX9100

Address    Device       Object

Launching: DXPasswd.exe
Verifying Password for : FL01.N2.DX {1} 
Sent Download Command to: FL01.N2.DX {1}
Downloading to: FL01.N2.DX {1}

C:\CONFIGFILES\MYCONFIG.DXF

ESSEN

gxuidwld

FL01.N2.DX {1}
FL01.N2.DX {4}

DX9100
DX9100

1
4

FL01

Connect Site

Warning: Connected Site will be disconnected.
Do you wish to continue?

Yes No

LoaderUI

lduiwarn
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6. Click on Yes to continue or No to cancel the new site
selection.

7. Click on the down arrow in the Supervisory Controller
field to select the N30 controller connected to the DX
controller. A list of the DX controllers connected to the
selected supervisory controller appears in the field
below, and the DX controller with the address selected
in the Download Via N30 box is highlighted.

8. Click on Download to initiate the download process. The
following dialog box appears:

Figure 109: DX Download Dialog Box

Note: When a check mark appears in the Log File box
(default) the program writes a series of messages to
the errorlog.txt file, recording download progress. The
errorlog.txt file is in the C: root directory. Click on the
Log File box to deselect this option.

9. Click on OK to continue or Cancel to stop the 
download selection process.

Note: If the DX controller supports the password protection
feature for upload/download (versions 1.4, 2.3, 3.3 or
later), and the password protection feature is enabled
in the GX9100.INI file (see Enabling Password
Protection for the DX-9100 Download/Upload
Dialogs under Software Installation at the beginning
of this guide), the Password dialog box appears:

DX9100 Download

CancelOK

Log File

gxdxdwn
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Figure 110: Password Dialog Box

If the password protection field is not enabled in the
GX9100.INI file, but the DX controller is password
protected, the Password dialog box will not appear,
and the download will fail.
If the DX controller is password protected, enter the
corresponding password and click on OK. The
password may be found under Global Data in the GX
configuration file that was last used to download the
controller. (See Defining the Global Data and
Password section earlier in this document.) If the
password is not correct, the download will fail and the
Password dialog box will reappear. After three
incorrect entries the download process will be
cancelled automatically.
If the DX is not password protected, click on OK to
continue.

Download progress is indicated by the progress bar in
the Loader UI dialog box, and a message box displays
the operational steps and commands of the Loader User
Interface program.
The download can be aborted at any time by clicking on
the Abort button.

10. When the download is complete, click on the Close
button to close the Loader UI dialog box and terminate
the Site Manager and Loader UI programs. A dialog box
appears with a download complete or download failed
message.
If the download is not successful, refer to the errorlog.txt
file for the possible causes.

DX9100 Download

CancelOK

Enter Password:

gxdxpwd
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Note: It is recommended that you save the current
configuration before uploading, as the current
configuration on the screen will be replaced by the
configuration uploaded from the controller.

To upload the configuration from the DX controller via an
N30 Supervisory Controller to a PC with M-Tool software:
1. Select Upload Via N30 in the Action menu. The

following dialog box appears.

Figure 111: Upload Via N30 Dialog Box

2. Select the item you want to upload by clicking on the
corresponding radio button.

Note: Version 6.0 of the GX Tool, does not support the
upload and download of the XT/XTM module
configuration via the N30 using items DX and
XT/XTM or XT/XTM. Use a direct connection to the
controller to upload and download these modules.

3. In the Address data field, enter the address of the
controller to be uploaded. The address must be a number
between 1 and 255.

Note: An upload file will be created by the N30 upload
program. Files with DXU extensions contain DX and
XT/XTM configuration data, XTU files contain
XT/XTM configuration data only, and CLU files
contain calibration data only. The DX address will be
used by the N30 upload program to locate the
controller on the N2 Bus.

Uploading

gxn30upl

Upload Via N30

Cancel

OK

Item

DX

DX and XT/XTM

XT/XTM

Calibration

Address 0
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4. Click on OK and the Loader UI program will be
launched.

Note: If the Loader User Interface program
(loaderui.exe) cannot be located, the following
dialog box appears:

Figure 112:  Loader UI Not Found Dialog Box

When the Loader User Interface program has been
successfully launched, the following dialog box
appears:

Figure 113:  Loader UI Dialog Box for Upload

gxnotfou

GX9100

Loader UI not found. 
Check the path in GX9100.ini file.

OK

File Name:

Loader UI

Site Name:

Supervisory Controller:

Browse...

Download

Upload

Abort

Close

DX9100

Address    Device       Object

Launching: DXPasswd.exe
Verifying Password for : FL01.N2.DX {1} 
Sent Upload Command to: FL01.N2.DX {1}
Uploading to: FL01.N2.DX {1}

C:\CONFIGFILES\MYCONFIG.DXF

ESSEN

gxuiupld

FL01.N2.DX {1}
FL01.N2.DX {4}

DX9100
DX9100

1
4

FL01

Connect Site
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Note: The File Name is the path name of the open
configuration in the GX-9100 Tool with the extension
DXU, XTU or CLU. It cannot be changed. If a
configuration has not been opened in the GX Tool, the
default file name is n2up.xxx.

4. The default site appears in the Site Name field. To select
a site other than the one displayed, click on the down
arrow in the Site Name field. Only those sites that are
defined in the Site Book, created by M-Tool software,
are shown. Click on the Connect Site button to launch
the Site Manager and establish connection with the
selected site. The Site Manager appears as a task bar
button on the Windows screen task bar. If a site is
already connected and another site is selected, the
following warning appears:

Figure 114:  Site Disconnect Warning for Upload

6. Click on the down arrow in the Supervisory Controller
field to select the N30 controller connected to the DX
controller. A list of the DX controllers connected to the
selected supervisory controller appears in the field
below, and the DX controller with the address selected
in the Upload Via N30 box is highlighted.

7. Click on Upload to initiate the upload process. The
following dialog box appears:

Figure 115: DX Upload Dialog Box

Warning: Connected Site will be disconnected.
Do you wish to continue?

Yes No

LoaderUI

lduiwarn

DX9100 Upload

CancelOK

Log File

gxdxupl
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Note: When a check mark appears in the Log File box
(default) the program writes a series of messages to
errorlog.txt file, recording upload progress. The
errorlog.txt file is in the C: root directory. Click on the
Log File box to deselect this option.

8. Click on OK to continue or Cancel to stop the 
upload selection process.

Note: If the DX controller supports the password protection
feature for upload/download (versions 1.4, 2.3, 3.3 or
later), and the password protection feature is enabled
in the GX9100.INI file (see Enabling Password
Protection for the DX-9100 Download/Upload
Dialogs under Software Installation at the beginning
of this guide), the Password dialog box appears:

Figure 116: Password Dialog Box

If the password protection field is not enabled in the
GX9100.INI file, but the DX controller is password
protected, the Password dialog box will not appear,
and the upload will fail.
If the DX controller is password protected, enter the
corresponding password and click on OK. The
password may be found under Global Data in the GX
configuration file that was last used to download the
controller. (See Defining the Global Data and
Password section earlier in this document.) If the
password is not correct, the upload will fail and the
Password dialog box will reappear. After three
incorrect entries the upload process will be cancelled
automatically.

DX9100 Upload

CancelOK

Enter Password:

gxdxpwu
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If the DX is not password protected, click on OK to
continue.
Upload progress is indicated by the progress bar in the
Loader UI dialog box, and a message box displays the
operational steps and commands of the Loader User
Interface program.

9. When the upload is complete, click on the Close button
to close the Loader UI dialog box and terminate the Site
Manager and Loader UI programs. A box appears with
an upload complete or upload failed message.
If the upload is not successful, refer to the errorlog.txt
file for the possible causes.

10. If the upload is successful, click on OK to continue.
Upload then checks whether the configuration that is
open in the GX Tool matches the configuration uploaded
from the controller (unless you are uploading a
calibration).  Upload DX checks only for DX elements
and upload XT/XTM checks against XT1/XTM1 and its
associated EXPs. Upload DX and XT/XTM checks both.
If the check fails, the following dialog box appears:

MYCONFIG

Modules do not match.
Upload will overwrite the current configuration.
OK to continue?

CancelOK

Figure 117:  Modules Do Not Match Dialog Box

11. Select OK to continue uploading the configuration.  The
configuration appears on the screen when the upload is
completed, and the configuration data can be saved.
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Configuring the DX LCD
Display

The process for configuring the DX LCD Display is shown
below:

Start the GX-9100 Program.

If you wish to use the User Names,
Descriptions, and Units already assigned

to points in a DX-9100 configuration,
then load that configuration into the GX

Tool.

Define a User Config Code if not already
defined in the DX-9100 configuration file.

Define the Global Data for the display.

Define the Configuration Name for the
display configuration.

Define a Point Database for the display.

Define TSn/OSn Module Descriptions.

Define Trend Data.

If the configuration is to be used as the
default, then select it as the default.

Download the configuration and/or Home
Page to the display.

Figure 118:  DX LCD Display Configuration Process

Configuration
Process
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This section describes the user interface elements of the GX
Tool that support the DX LCD Display.
Note: In this section, the terms “click” and “double click”

always refer to the left mouse button unless it is
explicitly stated that you use the right mouse button
(to bring up pop-up menus, for example).

The menu bar is across the top of the GX-9100 main
window.  Click on a menu item to display a drop-down
menu listing the corresponding menu options.  The menu
bar, shown in Figure 119 below, contains eight menu items.
Only the DX LCD Display menu options are described in
this section.

File Edit View Action Controller Window DX LCD Display Help
GX9100 - [Untitled]

New menu option for the
DX LCD Display.

Figure 119:  GX-9100 Main Menu Bar

A detailed description of the options on the DX LCD
Display menu follows.

User
Interface

Menu Bar of
the Main
GX-9100
Window
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DX LCD Display Menu
The DX LCD Display menu contains all the options required
to define a configuration for the DX LCD Display.

Figure 120:  DX LCD Display Menu
ctgxmen1

Download Display...
Read User Configuration Codes...

Define Default Configuration...

TSn/OSn Description Text
Point Database

Configuration Name...
Global Data...

DX LCD Display

Define Trend Data

F irmware Version...

U pload Display
Up date Firmware
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The table below describes the DX LCD Display menu
options:

Table 16:  DX LCD Display Menu Options
Menu Option Description
Firmware Version… Allows you to select firmware Version 2.01x or Version

3.00.00 or higher.
Global Data Allows you to edit global data that affects the operation

of the display as a whole, such as the time-out period of
the LCD back-light.

Configuration Name Allows you to edit the Configuration Name.
Define Default
Configuration

Allows you to define a default configuration to be used
by the DX LCD Display in the event that none of the
configurations stored in the unit matches the DX
controller configuration.

Point Database Opens a new window that allows you to define the
points that are to be shown on the LCD display.

TSn/OSn Description Text Opens a new window that allows you to edit the
descriptions for Time Schedule modules and Optimal
Start/Stop modules.

Define Trend Data Opens a new window that allows you to define the
points for which Trend Data is to be shown on the DX
LCD display.

Download Display Allows you to download the current configuration to the
display unit.

Upload Display Allows you to upload a configuration from the display
unit to the GX Tool on the PC.

Update Firmware Allows you to update Version 3.00.00 and higher
firmware. Only appears if enabled in the GX9100.INI
file. (See the Software Installation section for more
details.)
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As noted in Table 16, the Point Database, TSn/OSn
Description Text, and Define Trend Data options on the
DX LCD Display menu open new windows.  These are data
entry windows for the DX LCD Display, and they coexist
with the main GX-9100 window, as shown in Figure 121
below:

File Edit Window Help

11:05:30 Friday, February 7, 1997

GX9100 - Untitled

AI2
AI3
AI4
AI5
AI6
AI7
AI8

AI1

DI1
DI2
DI3
DI4
DI5
DI6
DI7
DI8

AO1
AO2
AO9
AO10
AO11
AO12
AO13
AO14
DO3
DO4
DO5
DO6
DO7
DO8

Untitled

Screen 1

Description Units Alarm Command

Untitled - DX LCD Display - Point Database

Main GX-9100 Window
DX LCD Display Data Entry Window

Figure 121:  Main and Data Entry Windows

Only one window is the active window (i.e., the window that
accepts user input) at any given time.  You switch between
windows by clicking with the mouse on the window you
want to make active, or by clicking on the control box  in
the upper left corner of the active window and then choosing
Next from the menu that appears.  You can also use the
Ctrl + F6 keyboard shortcut to activate each window in turn.
Note: The options on the menu bar may change to

correspond to the currently active window.

DX LCD
Display Data
Entry
Windows
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As noted under the previous subheading, the options on the
menu bar change when one of the DX LCD Display data
entry windows becomes the active window.  Both types of
data entry windows have the same options on the menu bar,
an example of which is shown in Figure 121 on the previous
page.  A detailed description of the options on each menu
follows:
File Menu
The File menu (Figure 122) contains options to save and
print the data of the data entry window.

Print Preview
Print

Save

NewNew

File

OpenOpen

ExitExit

Figure 122:  File Menu

Table 17 below describes the File menu options:

Table 17:  File Menu Options
Menu Option Description
New No function in this version of the configuration tool.  The option is

grayed and unavailable.
Open No function in this version of the configuration tool.  The option is

grayed and unavailable.
Save Saves the data of the data entry window within the current controller

configuration in memory.  Note that this does not write the data to the
computer’s disk.  To do that, first make the main configuration window
the active window (by clicking on it), and then click on the Save button

 on the tool bar, or select Save or Save As from the File menu on the
main menu bar.  The display configuration is saved in the same file as
the controller configuration.

Print Prints the data of the data entry window in tabular form.
Print Preview Allows you to view the data of the data entry window as it will be printed

on the page.
Exit No function in this version of the configuration tool.  The option is

grayed and unavailable.

DX LCD
Display Data
Entry Menu
Bar
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Edit Menu
The Edit menu (Figure 123) contains options to enter and
manipulate data in the data entry window.

Edit

Delete
Paste
Copy
Cut
Data

Figure 123:  Edit Menu

Table 18 below describes the Edit menu options:

Table 18:  Edit Menu Options
Menu Option Description
Data Allows you to enter and/or edit the data of the

currently selected (highlighted) line in the data
entry window.

Cut Removes the currently selected data and places it
on the clipboard.

Copy Places a copy of the currently selected data on the
clipboard.

Paste Pastes the data from the clipboard into the
currently selected line.

Delete Deletes the currently selected data without placing
it on the clipboard.
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Window Menu
The Window menu (Figure 124) contains options to cascade,
tile, and arrange multiple windows and icons on the screen.

Window

Arrange
Tile
Cascade

Figure 124:  Window Menu

Table 19 below describes the Window menu options:

Table 19:  Window Menu Options
Menu Option Description
Cascade Arranges multiple windows on the screen in an

overlapping “stair-stepped” fashion.
Tile Arranges multiple windows on the screen so that

all are visible in a non-overlapping fashion.
Arrange Arranges icons (minimized windows) to be aligned

at the bottom of the screen.

Help Menu
The Help menu (Figure 125) contains one option that
displays copyright and version information for the
configuration tool.

Help

About...

Figure 125:  Help Menu

Table 20 below describes the single option on the Help
menu:

Table 20:  Help Menu Option
Menu Option Description
About Displays copyright and version information for the

GX Tool.
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The tool bar, located just below the menu bar, contains
buttons that perform specific functions when you click on
them with the mouse.  Table 21 describes the tool bar
buttons that are new in this version of the GX Tool.
Note: Depending on the window that is currently active,

some of the tool bar buttons may be grayed and
unavailable.

Table 21:  New Tool Bar Buttons
Tool Bar
Button

Menu Bar
Equivalent

Description

Edit--Cut Removes the currently selected data
and places it on the clipboard.

Edit--Copy Places a copy of the currently selected
data on the clipboard.

Edit--Paste Pastes the data from the clipboard into
the currently selected line.

Tool Bar
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A pop-up menu appears when you use the right mouse
button to click on any line of a table in any of the DX LCD
Display data entry windows.  If the line was not already
selected (i.e., highlighted in reverse video) when you click
on it, then the highlight is moved to that line before the
menu is displayed.  The options on the pop-up menu depend
on the window in which you are working.  Examples are
shown in the next two figures.
An example of the pop-up menu that appears in the Point
Database window when you click on a Point Data line with
the right mouse button is shown in Figure 126 below:

File Edit Window Help

11:05:30 Friday, February 7, 1997

Screen 2

Description Units Alarm Command

Screen 1

Description Units Alarm Command

GX9100 - [Untitled- DX LCD Display - Point Database]

Delete
Paste
Copy
Cut
Data

Figure 126:  Point Database Pop-up Menu

Pop-up Menus
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An example of the pop-up menu that appears in the
TSn/OSn Descriptive Text window when you right click on
a Time Schedule module or Optimal Start/Stop module is
shown in Figure 127 below.

File Edit Window Help

11:05:30 Friday, February 7, 1997

Optimal Start/Stop Module Description Text

Description
OS1 Optimal Start1
OS1 Optimal Start2

Time Schedule Module Description Text

Description
TS1 Time Schedule1
TS2 Time Schedule2
TS3 Time Schedule3
TS4 Time Schedule4
TS5 Time Schedule5
TS6 Time Schedule6
TS7 Time Schedule7
TS8 Time Schedule8

GX9100 - [Untitled- DX LCD Display -TSn/OSn Description

Delete
Data

Figure 127:  Time Schedule Module Pop-up Menu

Select an option on the pop-up menu by clicking on it with
the mouse, or highlighting it with the arrow keys and then
pressing Enter.  Click outside of the menu, or press Esc, to
exit the menu without choosing an option.
Note: The options on the pop-up menus are the same as

those under the Edit menu on the menu bar.



124     Configuration Tools—GX-9100 User’s Guide

To define the global data for the DX LCD Display:
1. Select Global Data from the DX LCD Display menu.

The Global Data dialog box shown in Figure 128
appears:

Figure 128:  DX LCD Display Global Data Dialog
Box

2. Fill in the following fields in the dialog box:

Table 22:  Global Data Fields
Field Description
Passwords Enter a Level 1 password (allows the user to

perform all functions) and a Level 2 password (only
allows the user to perform adjust commands).  Both
passwords are 4-digit numbers from 0000 to 9999.

Password
Time-out

Enter the time of user inactivity after which the
password must be re-entered.  The range is from 1
to 1440 minutes.  Enter 0 to disable the password
time-out.

LCD Backlight
Time-out

Enter the time of user inactivity after which the
display panel’s backlight is automatically switched
off.  The range is from 1 to 30 minutes.

Continued on the next page…

Defining the
DX LCD
Display
Global Data

DX LCD Display - Global Data

(All functions)Level 1

(Adjust only)Level 2

1-1440 mins
0=Disable

1-30 mins

Password time-out

Passwords

LCD Backlight time-out

Cancel

OK

PC Port Clock Format

12 hour
24 hour

COM2
COM1

File

5

Choose Dir.Choose Dir.

ctgxmen2

Enter Addresses and or
ranges to be polled
separated by commas

Device Poll

1-255

Enable N2 Bus Operation

Home Page

Enable Multiple
Home Page Display
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Field (Con't.) Description
PC Port Select the serial port to which the display panel is

connected on the PC running the GX Tool.  COM1
is serial port 1 and COM2 is serial port 2.  You can
also select File to save the configuration data to a
file instead of downloading it directly to the display
panel (see File Destination for Downloading later in
this section).

Clock Format Select whether the display panel is to show the time
in 12 or 24 hour format.

Device Poll Enter addresses and/or ranges to be polled,
separated by commas. Choose whether to enable
N2 Bus Operation.

Home Page Choose whether all custom home pages can be
accessed from an active configuration.

3. Click on OK to save the values and close the dialog box.

The Enable Multiple Home Page Display option is intended
primarily for monitoring a single DX that controls multiple
equipment. It allows an individual graphic representation of
up to eight items of equipment.
If the DX LCD can connect to more than one DX controller,
you must make sure that the source items for dynamic data
in all Home Pages are configured in the same way in each
controller. For example, if a Home Page shows "Outdoor
Temperature" and is mapped to Item AI1, then you must
configure each DX controller such that AI1 measures the
outdoor temperature.

Multiple Home
Page Display
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If you select File as the PC Port in the Global Data dialog
box (Figure 128), then the Choose Dir button is activated
(i.e., the button text turns black and the button can be
selected).  The File option causes the display panel
configuration data to be written to a file when you choose
Download Display from the DX LCD Display menu.  The
file is named using the numerical Configuration Code, and a
file name extension of .dse, and is intended for use with an
emulator program that may become available in the future.
For example, the file would be named 99.dse if the
Configuration Code is 99.  The Configuration Code is
defined in the User Config Code field of the Global Data
dialog box for the main controller configuration (found
under the Edit menu of the main window).  Three additional
files are created to provide Home Page data and system
information for the emulator:  h99.dse, common.dse,
and fonts.dse.
To specify the directory (folder) on your PC where the
download files are to be stored:
1. Click on File for the PC Port in the Global Data dialog

box (Figure 128).  The Choose Dir button is activated
and can be selected.

2. Click on the Choose Dir button in the Global Data
dialog box (Figure 128).  The Choose Directory dialog
box appears, as shown in Figure 129 below:

Choose Directory

Folders:

c:\gx9100

c:\
Cancel

OK

Drives:

Network...

c:

gx9100

Figure 129:  Choose Directory Dialog Box

File
Destination for
Downloading
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3. Select the drive and/or directory (folder) where the
download files are to be stored, then click OK to save
the destination and close the dialog box.

To define the DX LCD Display configuration name:
1. Select Configuration Name from the DX LCD Display

menu.  The Configuration Name dialog box appears, as
shown in Figure 130:

DX LCD Display - Change/Edit Configuration Name

Configuration Name
(16 char.)

User Configuration Code ->

Cancel

OK

Figure 130:  Configuration Name Dialog Box

2. Type in the configuration name, using up to 16
characters.

Note: A User Configuration Code is required for
downloading. If you have already defined a User
Config Code in the controller’s Global Data dialog
box (found under the Edit menu of the main window),
then this code is shown in the User Configuration
Code field. If not, return to the Global Data dialog
box and enter a number (0-9999).
If you have already defined a Job Name in the Job
Information dialog box (also found under the Edit
menu), then the first 16 characters of this name are
shown in the Configuration Name field.  In this case
you may accept or edit the name as you wish.  This
has no effect on the Job Name defined in the Job
Information dialog box.

3.  Click OK to save the name and configuration code and
close the dialog box.

Defining the
Configuration
Name
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The DX LCD Display can store up to eight separate display
configurations.  Each configuration is identified by a
configuration name and configuration code.  For the
procedure that allows you to read the configuration names
and codes stored in the display unit, refer to Displaying the
Configuration Codes later in this section.
When you attach the DX LCD Display to a DX controller,
the display attempts to match one of its stored configuration
codes with the User Config Code defined in the DX
controller’s configuration.  If it finds a match, then the DX
LCD Display uses the corresponding display configuration.
For those cases where the display unit does not find a match,
you can use this menu option to tell the unit to use a default
configuration and you select which of the eight stored
configurations should be the default.  If the default
configuration feature is not enabled, the display shows a
“Configuration not found” message.  To enable and select a
default configuration:
1. Select Define Default Configuration from the DX LCD

Display menu.  The Define Default Configuration dialog
box shown in Figure 131 appears:

DX LCD Display - Define Default Configuration

Cancel

OK

5

Position Number

Enable Default Configuration

6

7

8

1

2

3

4

Figure 131:  Define Default Configuration Dialog
Box

2. Place a check mark in the Enable Default Configuration
box by clicking on it if you want the display unit to use a
default configuration when it cannot find a match for the
configuration code of the DX controller to which it is
connected.  Note that if the box is not checked, the
Position Numbers are grayed and unavailable.

Defining the
Default
Configuration
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3. Click on one of the Position Numbers (from 1 to 8) to
select the configuration stored in that position as the
default configuration.

4. Click OK to save your changes, or Cancel to close the
dialog box without saving your changes.

Note: The default configuration data is stored in the DX
LCD Display.  Make sure to download the display
configuration to the display after you make changes in
the Define Default Configuration dialog box.

If you selected File as the PC Port in the DX LCD Display
Global Data dialog box (Figure 128), then the Define
Default Configuration procedure changes.  To enable and
select a default configuration when the download destination
is a file:
1. Select Define Default Configuration from the DX LCD

Display menu.  The Define Default Configuration dialog
box shown in Figure 132 appears:

Default Configuration Number

Cancel

OKEnable Default Configuration

Default Configuration Number 00

Figure 132:  Default Configuration Dialog Box
for a File Destination

2. Place a check mark in the Enable Default Configuration
box by clicking on it if you want the emulator program
to use a default configuration when it cannot find a
match for the configuration code in the DX controller to
which it is attached.  Note that if the box is not checked,
the Default Configuration Number field is grayed and
cannot be edited.

3. Type the configuration code of the configuration you
want to use as the default configuration in the Default
Configuration Number field.

4. Click OK to save your changes, or Cancel to close the
dialog box without saving your changes.

Default
Configuration
When
Downloading
to a File
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The point data base defines which points of the DX
controller are to be shown and monitored by the DX LCD
Display.  The point data base is defined in a separate
window of the GX Tool.  To open the Point Database
window:
Select Point Database from the DX LCD Display menu.  A
new window named DX LCD Display Point Database
appears, as shown in Figure 133 below:

File Edit Window Help

11:05:30 Friday, February 7, 1997

Screen 2

Description Units Alarm Command

Screen 1

Description Units Alarm Command

GX9100 - [Untitled- DX LCD Display - Point Database]

Figure 133:  DX LCD Display Point Database
Window

The Point Database window contains eight separate tables
with twelve rows per table, each table representing one of
the eight Point Data screens of the display.  The procedures
for adding new points to a table, editing point definitions,
deleting points, copying points, moving points, and saving
the point data base, are described under separate
subheadings in the remainder of this section.

Defining the
Point Data
Base
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To define a new point to be displayed on the DX LCD Display:
1. Select the desired position of the point on one of the

eight Point Data screens by clicking on the
corresponding row in the table representing the screen.
The selected row is highlighted in reverse video.

2. Click on the selected row with the right mouse button
and select Data from the pop-up menu that appears, or
select Data from the Edit menu.  The Data dialog box
appears, as shown in the figure below:

Data

Tag Name

Enter the Tag Name or * to select.

Cancel

OK
*

Figure 134:  Data Dialog Box

3. Enter the tag name of the new point, or type an
asterisk (*) to select the item from a list.  (An asterisk is
the default entry when the dialog box opens.)  Click OK
to continue to the next dialog box.  The next dialog box
that appears depends on what you entered for the Tag
Name:

• If you entered a specific tag name, such as AI1, the
next dialog box is the point-specific Data dialog box
for the selected point.  Skip to Step 7 in this
procedure, which describes the point-specific Data
dialog boxes.

• If you entered an asterisk (*), then a series of dialog
boxes appear that allow you to select from point-type
categories and sub-categories until you have found the
individual point that you want to add.  Continue with
the next step (Step 4) in this procedure.

Note: The terms Tag Name and Item Name (or Item) are
used interchangeably throughout the GX Tool. Both
terms refer to the controller item abbreviations (e.g.,
AI1 for Analog Input 1), as shown in the item lists
found in this and other documents.

Adding a New
Point to be
Displayed



132     Configuration Tools—GX-9100 User’s Guide

4. If you entered an asterisk (*) in the Tag Name field of
the Data dialog box, then a dialog box showing point-
type categories appears, as shown in the Figure 119
below:

Select

Cancel

OK

Network Input/Output
Internal Points
Programmable Modules
DX Input/Output

Figure 135:  Select Point Category Dialog Box

Note: The category Network Input/Output is only shown if
you have selected DX Version 3.0, or later, as the
controller type in the Controller menu on the main
menu bar.

5. Select a category by double clicking on it, or by clicking
on it to highlight it and then clicking OK.  Another
dialog box appears listing sub-categories of the category
you chose in the previous dialog box.  For example, if
you chose DX Input/Output in Figure 119, the dialog
box shown in the figure below appears:

Select

Cancel

OK

Digital Output3-8
Analog Output1-2
Digital Input1-8
Analog Input1-8

Analog Output9-14
Value of Analog Source DO 3-8

XTn Digital Output1-8
XTn Analog Output1-8
XTn Digital Input1-8
XTn Analog Input1-8

Figure 136:  Select Sub-category Dialog Box
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6. Select a sub-category by double clicking on it, or by
clicking on it to highlight it and then clicking OK.
Another dialog box appears listing either additional
sub-categories or individual points.  For example, if you
chose Analog Input in Figure 120, a dialog box listing
individual points appears, as shown in Figure 121
below:

Select

Cancel

OK

AI4
AI3
AI2
AI1

AI6
AI5

AI8
AI7

Figure 137:  Select Point Dialog Box

Note: There may be several dialog boxes listing
sub-categories before you reach the dialog box listing
individual points.  Simply repeat Step 6 until you find
the point you want to add to the table.

7. Select the individual point you want to add to the table
by double clicking on it, or by clicking on it to highlight
it and then clicking OK.  Another dialog box appears,
allowing you to define point-specific data and
parameters for the point.  The fields in the dialog box
depend on the type of point.  For example, if you chose
AI1, the dialog box shown in Figure 138 appears:

Data

Description
(16 char.)

Tag AI1

Cancel

OK

Alarm

Display Units
(6 char.)

AI1

Figure 138:  Analog Input Data Dialog Box

Fill in the fields and click OK to save the data.  The
fields are described later in this section.
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All of the point-specific data dialog boxes have three fields
in common, as shown in Table 23 below:

Table 23:  Fields in All Point Data Dialog Boxes
Field Description
Tag Shows the Tag (Item) name of the point you

selected.
Description Enter a freely definable plain text description for the

point, using up to 16 characters.  The default text in
the Description field is taken from the main
configuration data base, using the following criteria:
1. If a description is defined for the point in the

main data base (i.e., by selecting Data from the
Edit menu in the main GX-9100 window), then
the first 16 characters of this description are
shown as the default.

2. If no description is defined for the point, but a
User Name is defined, then the User Name is
shown as the default.

3. If neither a description nor User Name is defined
for the point, then the Tag Name is shown as the
default.

You can accept or edit the default Description as you
wish.  This has no effect on the text defined in the
main data base from which the default was taken.

Display Units Enter the engineering units (up to six characters)
that are to be displayed for the point on the DX LCD
Display.  Note that there are two fields for digital
(i.e., binary or 2-state) points: one for the State 0
units and one for the State 1 units.
For some points there may be a default value in the
Display Units field if you have already defined the
point’s Measurement Units in the main data base
(i.e., by selecting Data from the Edit menu in the
main GX-9100 window).  In this case you may
accept or edit the units as you wish.  This has no
effect on the Measurement Units defined in the main
data base.

For the purposes of the DX LCD Display, all of the points
you can add to the point data base are one of four basic types:

• Analog input type

• Analog output type

• Digital input type

• Digital output type
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The remaining fields in the point-specific data dialog boxes
depend on the type, and are described under separate
subheadings in the remainder of this section.

Analog Input Type
For an analog input type, a point-specific data dialog box
similar to Figure 139 appears:

Data

Description
(16 char.)

Tag AI1

Cancel

OK

Alarm

Display Units
(6 char.)

AI1

Figure 139:  Analog Input Data Dialog Box

Table 24:  Fields for an Analog Input Type
Field Description
Alarm Check this box (by clicking on it) to define that the

alarm limits of the point be monitored by the DX
LCD Display and an alarm generated on the unit
when the point’s value goes outside of the limits.
This option is only available for physical input
points that have alarm limits.

For Network Analog Inputs, the three fields shown below appear
in the dialog box instead of the Alarm field:
Command Check this box (by clicking on it) to define that the

point can be commanded from the DX LCD
Display.  If this box is not checked, the next two
fields are grayed and unavailable.

Minimum
Commandable
Value

Enter the minimum value to which the user can
command the point from the DX LCD Display.  The
allowable range is shown in parentheses.

Maximum
Commandable
Value

Enter the maximum value to which the user can
command the point from the DX LCD Display.  The
allowable range is shown in parentheses.

Note: A Network Analog Input should only be configured for
Command for testing and commissioning purposes.  During
normal operation, the input is set by a network output of
another controller on the network.
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Analog Output Type
For an analog output type, a point-specific data dialog box
similar to Figure 140 appears:

Data

Description
(16 char.)

Tag OUT1

Cancel

OK

Display Units
(6 char.)

Command

0

100

OUT1

Minimum Commandable Value
(0 to 100)

Maximum Commandable Value
(0 to 100)

Minimum Commandable Value
(0 to 100)

Maximum Commandable Value
(0 to 100)

Figure 140:  Analog Output Data Dialog Box

Table 25:  Fields for an Analog Output Type
Field Description
Command Check this box (by clicking on it) to define that the

point can be commanded from the DX LCD
Display.  If this box is not checked, the next two
fields are grayed and unavailable.  For some
points, the box itself may be grayed, indicating that
it is not possible to command the point.

Minimum
Commandable
Value

Enter the minimum value to which the user can
command the point from the DX LCD Display.  The
allowable range is shown in parentheses, and the
default value in the field is the lowest value of this
range.

Maximum
Commandable
Value

Enter the maximum value to which the user can
command the point from the DX LCD Display.  The
allowable range is shown in parentheses, and the
default value in the field is the highest value of this
range.

Note: For some points that cannot be commanded (such as the
Network Analog Outputs), the three fields shown above do
not appear in the dialog box.
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Digital Input Type
For a digital input type, a point-specific data dialog box
similar to Figure 141 appears:

Data

Description
(16 char.)

Tag DI1

Cancel

OK

State 0
Display Units
(6 char.)

State 1

None State 0 State 1

Alarm

DI1

Figure 141:  Digital Input Data Dialog Box

Table 26:  Fields for a Digital Input Type
Field Description
Alarm Click on the appropriate option (None, State 0, or

State 1) to define which state of the point
generates an alarm on the DX LCD Display.

For Network Digital Inputs, the field shown below also appears
at the bottom of the dialog box.
Command Check this box (by clicking on it) to define that the

point can be commanded from the DX LCD
Display.

Note: A Network Digital Input should only be configured for
Command for testing and commissioning purposes.  During
normal operation, the input is set by a network output of
another controller on the network.
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Digital Output Type
For a digital output type, a point-specific data dialog box
similar to Figure 142 appears:

Data

Description
(16 char.)

Tag DO3

Cancel

OK

State 0
Display Units
(6 char.)

State 1

Command

DO3

Figure 142:  Digital Output Data Dialog Box

Table 27:  Fields for a Digital Output Type
Field Description
Command Check this box (by clicking on it) to define that the

point can be commanded from the DX LCD
Display.  For some points, the box may be grayed,
indicating that it is not possible to command the
point.

Note: For some points that cannot be commanded (such as the
Network Digital Outputs), the field shown above does not
appear in the dialog box.

Note: Only those points that have been defined as On/Off,
Start/Stop, or Pulse should be added as a digital
output type, i.e., included in the data base via the
DO3-DO8 items.  For DAT and PAT outputs, include
the value of the analog source in the data base instead
of the DO3-DO8 items.

Note: For a full list of the points that can be defined for the
display, and whether or not they can be commanded,
refer to Appendix 4: DX LCD Display Items.
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To change the definition of a point that has already been
defined:
1. Select the point you want to change by clicking on it to

highlight it.
2. Click on the selected row with the right mouse button

and select Data from the pop-up menu that appears, or
select Data from the Edit menu.  The Data dialog box
appears, as shown in Figure 143 below:

Data

Tag Name

Enter the Tag Name or * to select.

Cancel

OK
DO3

Figure 143:  Data Dialog Box

Note that the originally defined Tag Name appears as the
default in the Tag Name field.

3. If you want to display a different point at the selected
position, enter a new tag name, or type an asterisk (*) to
select the new item from a list.  If you do not want to
change the point, simply click OK without editing the
Tag Name field.

4. Continue with the procedure described earlier under
Adding a New Point to be Displayed to change the data
and parameters of the point.  The fields of the
point-specific data dialog box contain the values already
defined for the point.

Changing a
Point
Definition
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To remove a point from the DX LCD Display data base:
1. Select the point you want to delete by clicking on it to

highlight it.  You can select more than one point by
dragging the mouse pointer over the points while
keeping the left mouse button depressed.  You can also
select more than one point by holding the Shift key
down (to select a block of consecutive points) or Ctrl
key down (to select a group of non-consecutive points)
when you click on the points.

2. Click on the selected point (or points) with the right
mouse button and select Delete from the pop-up menu
that appears, or select Delete from the Edit menu.

3. Click on Yes in the message box that appears to confirm
that you want to delete the point (or points).  Click on
No to cancel the operation.

To make a copy of a point in the DX LCD Display data
base:
1. Select the point you want to copy by clicking on it to

highlight it.  You can select more than one point by
dragging the mouse pointer over the points while
keeping the left mouse button depressed.  You can also
select more than one point by holding the Shift key
down (to select a block of consecutive points) or Ctrl
key down (to select a group of non-consecutive points)
when you click on the points.

2. Click on the selected point (or points) with the right
mouse button and select Copy from the pop-up menu
that appears, or select Copy from the Edit menu, or click
on the Copy button  on the tool bar.  A copy of the
selected point data is placed on the Windows clipboard.

3. Select the row where you want the copy to be placed by
clicking on it to highlight it.  If you are copying more
than one point, then this row marks the starting position
for the points.  If there is not enough room from the
starting position to insert all of the points, then the
remaining points are inserted on the next screen starting
at the first row.

Deleting a
Point

Copying a
Point
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4. Click on the highlighted row with the right mouse button
and select Paste from the pop-up menu that appears, or
select Paste from the Edit menu, or click on the Paste
button  on the tool bar.  A duplicate of the original
point data is pasted into the table starting at the selected
position.
If the paste operation would overwrite one or more
points that have already been defined in the table, then a
warning message appears asking you to confirm that you
want to continue with the operation.  If you continue, the
existing point data is overwritten and lost.
If you are pasting more than one point and the number of
rows required would go off the end of Screen 8 (the last
screen), then another warning message appears asking
you to confirm that you want to continue.  If you
continue, the rows up to the end of Screen 8 are filled
and the rest of the point data is not pasted (however, all
of the point data is still on the clipboard).

5. Edit the pasted point data, as required, using the
procedure described earlier under Changing a Point
Definition.  In particular, you may want to change the
duplicated Tag Names (Items) from those defined in the
original data, as described in Step 3 of that procedure.
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To move a point in the DX LCD Display data base:
1. Select the point you want to move by clicking on it to

highlight it.  You can select more than one point by
dragging the mouse pointer over the points while
keeping the left mouse button depressed.  You can also
select more than one point by holding the Shift key
down (to select a block of consecutive points) or Ctrl
key down (to select a group of non-consecutive points)
when you click on the points.

2. Click on the selected point (or points) with the right
mouse button and select Cut from the pop-up menu that
appears, or select Cut from the Edit menu, or click on the
Cut button  on the tool bar.  The selected point data is
removed from the table and placed on the Windows
clipboard.

3. Continue with the paste operation, which begins with
Step 3 of the procedure described earlier under Copying
a Point (the only difference being that the original data
is not duplicated in the table, but is removed from its
original position).

Moving a Point
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To save the DX LCD Display point data base and close the
Point Database window:
1. Save the point data base by clicking on the Save button

 on the tool bar, or by selecting Save from the File
menu.

Note: Saving the point data base only saves it within the
current controller configuration in memory, but does
not write the configuration to the computer’s disk.  To
do that, first make the main configuration window the
active window (by clicking on it), and then click on
the Save button  on the tool bar, or select Save or
Save As from the File menu on the main menu bar.
This saves all of the DX LCD Display configuration
data as well as the main DX controller configuration.
The display configuration data is saved in a separate
file with the same name as the DX controller
configuration file but with a .dsp extension.

2. Close the Point Database window by double clicking on
the control box  in the upper left corner of the window
(or at the left of the menu bar if the window is
maximized), or by clicking on the close box  in the
upper right corner of the window (or at the right of the
menu bar if the window is maximized).  The Point
Database window closes and the main configuration
window becomes the active window.

Note: You cannot exit the GX Tool if the Point Database
window is open.

Saving the
Point Data
Base
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A freely definable descriptive text string (up to 16
characters) can be associated with each Time Schedule
module and each Optimal Start/Stop module for display on
the DX LCD Display.  These descriptions are defined in a
separate window of the GX Tool.  To open the TSn/OSn
Description Text window:
Select TSn/OSn Description Text from the DX LCD Display
menu.  A new window named DX LCD Display TSn/OSn
Description Text appears, as shown in Figure 144 below:

File Edit Window Help
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Optimal Start/Stop Module Description Text

Description
OS1 OS1
OS2 OS2

Time Schedule Module Description Text

Description
TS1 TS1
TS2 TS2
TS3 TS3
TS4 TS4
TS5 TS5
TS6 TS6
TS7 TS7
TS8 TS8

GX9100 - [Untitled- DX LCD Display -TSn/OSn Description Text]

Figure 144:  TSn/OSn Description Text Window

The TSn/OSn Description Text window contains one
table for the Time Schedule modules and another for the
Optimal Start/Stop modules.  Default descriptions
appear in the Description field for each module, and they
are taken from the main configuration data base using
the following criteria:
1. If a description is defined for the module in the main

data base, then the first 16 characters of this
description are shown as the default.

2. If no description is defined for the module, but a
User Name is defined, then the User Name is shown
as the default.

Defining the
TSn/OSn
Module
Descriptions
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3. If neither a description nor User Name is defined for
the module, then the Tag Name is shown as the
default.

You can accept or edit the default Description as you
wish.  This has no effect on the text defined in the main
data base from which the default was taken.
The procedures for editing and saving the module
descriptions are described under separate subheadings in
the remainder of this section.

To edit a module description:
1. Select the module you want to edit by clicking on the

appropriate row in one of the tables.  The selected row is
highlighted in reverse video.

2. Click on the selected row with the right mouse button
and select Data from the pop-up menu that appears, or
select Data from the Edit menu.  A dialog box similar to
the one shown in Figure 145 appears:

Time Schedule Module Description TS1

Description
(16 char.)

Cancel

OK TS1

Figure 145:  Time Schedule Description Dialog Box

The name of the selected module appears in the title bar
of the dialog box, and the default description is
highlighted for editing.

3. Type the module description, using up to 16 characters,
in the Description field, or you may accept the default
description.  Click OK to save the description, or Cancel
to close the dialog box without saving your changes.

Editing a
Module
Description
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To delete a module description:
1. Select the module whose description you want to delete

by clicking on it to highlight it.  You can select more
than one module by dragging the mouse pointer over the
modules while keeping the left mouse button depressed.
You can also select more than one module by holding
the Shift key down (to select a block of consecutive
modules) or Ctrl key down (to select a group of
non-consecutive modules) when you click on the
modules.

2. Click on the selected module (or modules) with the right
mouse button and select Delete from the pop-up menu
that appears, or select Delete from the Edit menu.

3. Click Yes in the message box that appears to confirm
that you want to delete the description (or descriptions).
Click No to cancel the operation.

To save the TSn/OSn module descriptions and close the
TSn/OSn Description Text window:
1. Save your changes by clicking on the Save button  on

the tool bar, or by selecting Save from the File menu.
Note: Saving the descriptions only saves them within the

current controller configuration in memory, but does
not write the configuration to the computer’s disk.  To
do that, first make the main configuration window the
active window (by clicking on it), and then click on
the Save button  on the tool bar, or select Save or
Save As from the File menu on the main menu bar.
This saves all of the DX LCD Display configuration
data as well as the main DX controller configuration.
The display configuration data is saved in a separate
file with the same name as the DX controller
configuration file but with a .dsp extension.

2. Close the TSn/OSn Description Text window by double
clicking on the control box  in the upper left corner of
the window (or at the left of the menu bar if the window
is maximized), or by clicking on the close box  in the
upper right corner of the window (or at the right of the
menu bar if the window is maximized).  The TSn/OSn
Description Text window closes and the main
configuration window becomes the active window.

Deleting a
Module
Description

Saving the
TSn/OSn
Module
Descriptions
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Note: You cannot exit the GX Tool if the TSn/OSn
Definition window is open.

The DX controller can collect and store trend data for up to
12 analog and logic variables.  An analog variable
corresponds to an analog item in the DX controller, such as
an analog output.  A logic variable in the DX controller is a
byte value representing eight digital bits, such as the eight
digital inputs DI1 to DI8.  Trend data is collected for all
eight bits of the logic variable when any bit changes.
Note: Three prerequisite steps are required before you can

select the Define Trend Data option on the DX LCD
Display menu (the option is otherwise grayed and
unavailable):
1. The DX controller chosen in the controller

configuration (Controller option on the main menu
bar) must be a version that supports Trend Data.
(You can check this by seeing whether the Trend
option appears on the Add PM menu.)

2. You must have added a Trend Log Module to the
controller configuration (Trend option on the
Add PM menu).

3. You must have defined points to be trended in the
Trend Log Module of the controller configuration
(double click on the Trend Log Module).  These
points (and only these points) are automatically
inserted into the same positions of the DX LCD
Display Trend Data window.

To open the DX LCD Display Trend Data window:
Select Define Trend Data from the DX LCD Display menu.
A new window named DX LCD Display Trend Data
appears, as shown in Figure 146:

Defining
Trend Data
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Figure 146:  DX LCD Display Trend Data Window

The Trend Data window contains a table showing the points
from the Trend Log Module in the controller configuration.
The Item (Tag) names shown are the Items for which the DX
is configured to store trend data.  Digital Items (i.e., a logic
variable byte) are shown as a group reference (e.g., DI1..8).
For analog items, the description and units are taken from
the DX LCD Display Point Database if the point is defined
in the data base.  If it is not, the Tag name is used for the
description and there are no units.  If you later add the point
to the Point Database and then reopen the Trend Data
window, the point’s description and units are updated to
correspond to the Point Database.
For groups of digital items, the default description is the
group reference (e.g., DI1..8) and units do not apply.  You
can edit the description of the group in the Trend Data
window. The procedures for editing and saving the
descriptions are described under separate subheadings in the
remainder of this section.

File Edit Window Help
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Trend Log Data

GX9100 - [Untitled- DX LCD Display - Trend Data]

gtgxmen3

1
2
3
4
5
6
7
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DI1..8
AI2
XT1DI1..8

Room Temp

OA Temp
Lobby Lights

DI1..8
Deg C
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15/30

-30/40
- -
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No. Item Description Units Display Range



Configuration Tools—GX-9100 User’s Guide     149

To edit a group description:
1. Select the point you want to edit by clicking on the

appropriate row in the table.  The selected row is
highlighted in reverse video.

2. Click on the selected row with the right mouse button
and select Data from the pop-up menu that appears, or
select Data from the Edit menu.  If the point you selected
is an analog point, the Analog Trend dialog box shown
in Figure 147 appears.  If it is a group of digital points,
the Digital Trend dialog box shown in Figure 148
appears.

Figure 147:  Analog Trend Dialog Box

The Analog Trend dialog box shows the DX Trend
number, Tag name of the point, Description, and Units
as static text.  You cannot change any of these values
using the dialog box. However, the Display Range may
be changed from -32768 to +32767.

Editing a
Group
Description in
the Trend Data
Window

DX Trend -> 1

Tag -> AI1

Description -> Room Temp

Units -> Deg C

OK

Cancel

Display Range

15

35

Low Limit

High Limit

DX LCD Display - Trend Data

ctgxcmen4
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DX LCD Display - Trend Data

Item Description Units
DI1 Freeze Alarm Normal/Alarm
DI2 Fan Status Off/On
DI3 Thermal Overload Normal/Alarm
DI4 4 0/1
DI5 5 0/1
DI6 Filter Status Normal/Alarm
DI7 7 0/1
DI8 8 0/1

Description
(16 char.)

Cancel

OK

 DI1..8

DX Trend -> 2

Tag -> DI1..8

Figure 148:  Digital Trend Dialog Box

The Digital Trend dialog box shows the DX Trend
number, Tag names, Description, and the eight
individual digital items of the group.  For each item, the
description and units (state 0 and state 1 names) are
taken from the DX LCD Display Point Database if the
point is defined in the data base.  If it is not, the bit
number is used for the description, and 0 and 1 are used
for the units.  If you later add the point to the Point
Database and then redisplay the Digital Trend dialog
box, the point’s description and state names are updated
to correspond to the Point Database.

3. Type the group description, using up to 16 characters, in
the Description field, or you may accept the default
description.  Click OK to save the description, or Cancel
to close the dialog box without saving your changes.
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To save the digital trend group descriptions and close the
Trend Data window:
1. Save your changes by clicking on the Save button  on

the tool bar, or by selecting Save from the File menu.
Note: Saving the descriptions only saves them within the

current controller configuration in memory, but does
not write the configuration to the computer’s disk.  To
do that, first make the main configuration window the
active window (by clicking on it), and then click on
the Save button  on the tool bar, or select Save or
Save As from the File menu on the main menu bar.
This saves all of the DX LCD Display configuration
data as well as the main DX controller configuration.
The display configuration data is saved in a separate
file with the same name as the DX controller
configuration file but with a .dsp extension.

2. Close the Trend Data window by double clicking on the
control box  in the upper left corner of the window (or
at the left of the menu bar if the window is maximized),
or by clicking on the close box  in the upper right
corner of the window (or at the right of the menu bar if
the window is maximized).  The Trend Data window
closes and the main configuration window becomes the
active window.

Note: You cannot exit the GX Tool if the Trend Data
window is open.

Saving the
Trend Data
Definitions
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Up to eight separate display configurations can be stored in
the DX LCD Display.  Storing a configuration is
accomplished by downloading the configuration from the
GX Tool on the PC to the display unit through the PC serial
port to which the display unit is connected.
You can also download up to eight different Home Pages to
the display.  The Home Pages are customizable (see
Appendix 7), and can display live point data from the DX
controller.  Home Page definitions are stored in separate
files that have a file name extension of .hpg.  When you
open a configuration file in the GX Tool, it  automatically
looks for a home page file with the same name as the
configuration file but with the .hpg extension.  For
example, if you open a configuration file named
config1.dxs, the tool automatically opens the Home
Page file named config1.hpg.
Note: The GX Tool downloads a default Home Page (named

default.hpg) to the DX LCD display if it cannot
find a custom Home Page with the same name as the
open configuration file.

To download a configuration and/or Home Page to the DX
LCD Display:
1. If it is not open, open the DX controller configuration

file containing the display configuration you want to
download.  To do this, click on the Open button  on
the tool bar, or select Open from the File menu on the
main menu bar.  The File Open dialog box shown in
Figure 149 appears:

File Open

Folders:

c:\gx9100

c:\
Cancel

OK

Drives:

Network...gx9100

File name:

config1.dxs
config2.dxs
timesup.dxs
bldg3fl2.dxs

List files of type:

GX9100 Files (*.dxs) c:

 *.dxs

Figure 149:  File Open Dialog Box

Downloading
a Configura-
tion to the DX
LCD Display
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2. Select the configuration file you want to open and click
OK, or double click on the file name, to open the file.

3. Select Download Display from the DX LCD Display
menu.  The DX LCD Display Download dialog box
shown in Figure 150 appears:

DX LCD Display - Download

CancelOK

Download in Position

5 6 7 81 2 3 4

Point Database Home Page

Figure 150:  DX LCD Display Download Dialog Box

Note: When you select the Download Display menu option,
an error message appears if you have not yet specified
the PC Port to which the display unit is connected.
Specify the correct port in the DX LCD Display
Global Data dialog box (Figure 128) before
continuing.  Another error message may appear if you
have specified the PC Port, but the configuration tool
cannot detect a display panel connected to the port.  In
that case, check that the panel is properly connected to
the correct port, as described under under Connection
to the DX LCD Display earlier in this document, and
that the DX LCD Display is showing the
download/upload screen.

4. Place a check mark in the Point Database box by
clicking on it if you want to download the configuration
data to the display.

5. Place a check mark in the Home Page box by clicking on
it if you want to download the Home Page data to the
display.
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6. Click on one of the Position numbers (from 1 to 8) to
select the display unit storage location into which you
want to download the configuration and/or Home Page.
The default selection when you open the dialog box is
the next available free position in the display unit.  You
can accept the default, or choose another position by
clicking on it.

7. Click OK to begin the download operation, or click
Cancel to close the dialog box without downloading the
configuration.  If you are downloading a Home Page file,
the GX Tool performs a syntax check of the file’s
contents.  If the file fails the syntax check, the tool
generates a list of errors and warnings, and displays a
message box showing the results of the syntax check, as
shown in Figure 151:

Home Page Definition File Syntax Check

OK

2 Error(s),  1 Warning(s)

View Error Listing

Figure 151:  Syntax Check Results Message Box

8. If there were syntax errors in the Home Page file, click
on View Error Listing to open a new window showing
the errors and warnings generated by the syntax
check, or click OK to ignore the errors and continue the
download operation.

9. When the download operation completes, a message box
appears to inform you of whether or not the download
completed successfully (Figure 152).

GX9100

Download Complete

OK

Figure 152:  Download Complete Message Box
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Note: If a configuration and/or Home Page is already stored
in the selected position, then a warning message is
shown and you can choose whether to continue or
cancel the download operation.  If you continue, the
existing configuration and/or Home Page is
overwritten in the display.

If you selected File as the PC Port in the DX LCD Display
Global Data dialog box (Figure 128), then the Download
Display option writes the display panel configuration data to
a file instead of downloading it to a display unit.  The file is
intended for use with an emulator program that may become
available in the future.  The file is named using the
numerical Configuration Code, and a file name extension of
.dse.  For example, the file would be named 99.dse if
the Configuration Code is 99.  The Configuration Code is
defined in the User Config Code field of the Global Data
dialog box for the main controller configuration (found
under the Edit menu of the main window).  Three additional
files are created to provide Home Page data and system
information for the emulator:  h99.dse, common.dse,
and fonts.dse.
When downloading to a file destination, the previous
procedure (Downloading a Configuration to the DX LCD
Display) changes beginning with Step 3:
3. Select Download Display from the DX LCD Display

menu.  The message box shown in Figure 153 appears,
informing you that the configuration data will be written
to the file and directory (folder) shown as the path in the
message:

GX9100

Selected path for the emulator files is
C:\GX9100\0099.dse
C:\GX9100\h0099.dse

CancelOK

Figure 153:  Download to File Message Box

4. Click OK to write the configuration data to the file and
path shown in the message box.

Downloading
to a File
(for future use)
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Note: If a file of the same name already exists, then another
message box appears asking you to confirm that you
want to overwrite the file.  Click Yes in the message
box to continue, or click No to cancel the operation.

The DX LCD Display can store up to eight separate display
configurations.  Each configuration is identified by a name
and code.  To read the configuration codes and associated
names stored in the display unit:
1. Select Read Configuration Codes from the DX LCD

Display menu.  The User Configuration Codes dialog
box shown in Figure 154 appears:

DX LCD Display - User Configuration Codes

1

2

3

4

5

6

7

8

POSITION

OK

CONFIGURATION NAME

System (Default)

CODE

65535

HOME PAGE

Default

TREND

Not Defined

Chiller Plant1 Custom Defined

Boiler Plant2 Default Defined

Figure 154:  User Configuration Codes Dialog Box

For each configuration stored in the display unit, the
dialog box shows:  the storage position number, the
configuration code, the associated configuration name,
whether the configuration uses the default or a custom
Home Page, and whether Trend Data has been defined in
the configuration.  The default configuration, if defined,
is indicated by the word Default in parentheses after the
configuration name.

Displaying
the
Configuration
Codes
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Note: When you select the Read Configuration Codes menu
option, an appropriate error message appears if you
have not yet specified the PC Port in the DX LCD
Display Global Data dialog box (Figure 128), or if the
tool cannot detect a display panel attached to the port.

2. Click OK after you have read the codes to close the
dialog box.

Note: The Read Configuration Codes option on the DX
LCD Display menu is grayed and unavailable if you
have specified File as the PC Port in the DX LCD
Display Global Data dialog box (Figure 128).

To upload a configuration and/or Home Page from the DX
LCD Display unit to the GX Tool on the PC:
1. Create a new DX controller configuration file by

selecting New from the File menu or clicking on the New
button . Save the file to the PC hard disk by clicking on
the Save button  on the tool bar, or by selecting Save
from the File menu. Enter the file name to be used for all
the files that will be created during the upload process.

2. Select Upload Display from the DX LCD Display menu.
The DX LCD Display Upload dialog box shown below
appears:

Figure 155:  DX LCD Display Upload Dialog Box

Uploading a
Configuration
from the DX
LCD Display
Unit

DX LCD Display - Upload

CancelOK

Upload from Position

5 6 7 81 2 3 4

Point Database Home Page

ctgxmen5
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Note: When you select the Upload Display menu option, an
error message appears if you have not yet specified
the PC Port to which the display unit is connected.
Specify the correct port in the DX LCD Display
Global Data dialog box (Figure 128) before
continuing.  Another error message may appear if you
have specified the PC Port, but the configuration tool
cannot detect a display panel connected to the port.  In
that case, check that the panel is properly connected to
the correct port, as described under Connection to the
DX LCD Display earlier in this document.

3. Place a check mark in the Point Database box by
clicking on it if you want to upload the configuration
data to the GX Tool on the PC.

4. Place a check mark in the Home Page box by clicking on
it if you want to upload the Home Page data to the GX
Tool on the PC.

5. Click on one of the Position numbers (from 1 to 8) to
select the display unit storage location from which you
want to upload the configuration and/or Home Page.

6. Click OK to begin the upload operation, or click Cancel
to close the dialog box without uploading the
configuration.

7. If you click on OK, the box below appears asking you to
reconfirm. This is because the new configuration or
Home Page to be uploaded will overwrite the current
configuration or Home Page in the GX Tool. Click OK
to continue with the upload or click Cancel to close the
dialog box without uploading the configuration.

Figure 156:  Reconfirm Upload Box
ctgxmen7

GX9100

CancelOK

Upload will overwrite the current configuration!

OK to continue?
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8. When the upload operation is completed, a message box
appears to inform you whether the upload was
successful.

Figure 157:  Upload Complete Message Box

9. Save the uploaded file by clicking on the Save button 
on the tool bar.

This section only describes how to view a print preview, and
print, the DX LCD Display configuration data.  For other
printing options, such as setting header and footer options,
refer to the Printing Configurations section in the GX-9100
Software Configuration Tool for Windows User’s Guide
under Tab 5 in this manual.

To view how the DX LCD Display configuration data will
look when printed:
1. Select Print Preview from the File menu.  If the main

configuration window is the active window, the Print
Items dialog box shown in Figure 158 appears.  If one of
the DX LCD Display data entry windows is the active
window, then the Print Items dialog box is skipped and
the Print Preview window described in Step 5 appears.

Printing a
Configuration

Previewing the
Printed
Configuration

GX9100

Upload Complete

OK

ctgxmen6
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Figure 158:  Print Items Dialog Box

2. In the Selection section, click on Items (Listed below).
3. Select the desired Print Format:  Draft (without headers

and footers), or Final (with headers and footers).
4. In the Items section, click on DX LCD Display to place

a check mark in the box.  Select any other items you
wish to include in the print preview.

gxpritem

Print Items

Cancel

OK
All Items

Selection

Graphical Selection

Items (Listed below)

Draft

Print Format

Final

Data

Data Selection

Input Tags

Output Tags

Layout

Items

PMs

Inputs

Outputs

Network Inputs OST PLC Code DX LCD Display

TS PLC Global

XT Labels EXD Calibration

XTs DCO INFO

Network Outputs ACO LABELS

Trend
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5. Click OK in the Print Items dialog box and the Print
Preview window opens, similar to Figure 159 below:

11:05:30 Friday, February 7, 1997

Print... Next Page Prev PagePrev Page Zoom In Zoom OutZoom OutTwo Page Close

GX9100 - [Untitled]

DX LCD Display Information

Password (Adjust only) 1111
Password (All functions) 2222
Password Time-out (min) 5
Backlight Time-out (min) 5
Display ConfigName Test Site
Download Config No 2

TSOS Point Information

Time Schedule 1 Time Schedule1
Time Schedule 2 Time Schedule2
Time Schedule 3 Time Schedule3
Time Schedule 4 Time Schedule4
Time Schedule 5 Time Schedule5
Time Schedule 6 Time Schedule6
Time Schedule 7 Time Schedule7
Time Schedule 8 Time Schedule8
Optimal Start 1 Optimal Start1
Optimal Start 2 Optimal Start2

Point DataBase Information

Screen 1
_______________________________________________________________

Pos.Tag Description Units Alm Cmd Range
_______________________________________________________________

1 AI1 Analog Input Deg C YES NO
2 DI1 Binary Input Off/On YES NO
3 OUT1 Analog Output Level YES YES 0/100
5 DO3 Binary Output Low/High YES YES

Figure 159:  Print Preview Window

Note: If you opened the Print Preview window from one of
the DX LCD Display data entry windows, then only
the data of that window appears in the print preview.

6. Click Close to close the Print Preview window and
return to the window that was previously active.



162     Configuration Tools—GX-9100 User’s Guide

To print the DX LCD Display configuration data:
1. Click on the Print button  on the tool bar, or select

Print from the File menu.  If the main configuration
window is the active window, the Print Items dialog box
shown in Figure 160 appears.  If one of the DX LCD
Display data entry windows is the active window, then
the Print Items dialog box is skipped and the Print dialog
box described in Step 5 appears.

Figure 160:  Print Items Dialog Box

2. In the Selection section, click on Items (Listed below).
3. Select the desired Print Format:  Draft (without headers

and footers), or Final (with headers and footers).
4. In the Items section, click on DX LCD Display to place

a check mark in the box.  Select any other items you
wish to include in the printout.

Printing the
Configuration

gxpritem

Print Items

Cancel

OK
All Items

Selection

Graphical Selection

Items (Listed below)

Draft

Print Format

Final

Data

Data Selection

Input Tags

Output Tags

Layout

Items

PMs

Inputs

Outputs

Network Inputs OST PLC Code DX LCD Display

TS PLC Global

XT Labels EXD Calibration

XTs DCO INFO

Network Outputs ACO LABELS

Trend
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5. Click OK in the Print Items dialog box and the Print
dialog box shown in Figure 161 appears:

Print

Cancel

OKPrinter: Default Printer (HP LaserJet 4/4M
Post on LPT1:)

Collate Copies

From:

Setup...

Print Range

All

SelectionSelection

Pages

To:

Copies:

1

1Print Quality: 600 dpi

Figure 161:  Print Dialog Box

6. Select the desired Print Range by clicking on the
appropriate option.  Note that if you choose Page, you
also have to enter the starting and ending page numbers
in the From and To fields.

7. Select the Print Quality from the drop down list.  A
higher DPI (Dots per Inch) produces a better printout,
but may take longer to print.

8. Enter the number of copies you want in the Copies field.
If you are printing more than one copy and you want
each set of pages to be printed in the correct order, click
on Collate Copies to place a check mark in the box.

9. Click on the Setup button if you need to change any of
the printer options that Windows maintains.

10. Click OK to print the configuration data.
Note: If you started printing from one of the DX LCD

Display data entry windows, then only the data of that
window is printed.
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Importing DOS GX-9100 Files

If you have existing DX-9100 Controllers that have been
programmed using Version 2.0 of GX-9100 (DOS), use the
Import feature in the File menu to convert them to this
version.
1. Select Import from the File pull-down menu.  The

Import Dialog Box appears.
Import

Folders:

c:\gx9100

c:\
Cancel

OK

Drives:

Network...gx9100

File name:

fp011293.gps
ver1tst3.gps

List files of type:

Old GX9100 Files (*.gps) c:

 *.gps

Figure 162:  Import Dialog Box

2. Use standard Windows methods to select the proper
drive, directory, and file to import.
If you need to change the server, select the Network
button.  The Map Network Drive dialog box appears.  If
you need additional assistance concerning this screen,
consult your network administrator.

Map Network Drive

Cancel

OKDrive:

Path:

D:

Reconnect at logon

Figure 163:  Map Network Drive Dialog Box
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3. After highlighting the correct old file (.GPS) in the
Import Dialog Box, select OK to convert it.

4. If there is an existing configuration already in the GX
Tool, and it has been modified, the following dialog box
appears.  If it has already been saved, the line “The
changes are not saved!” does not appear.

GX9100

The changes are not saved!

Import will overwrite the current configuration

OK to continue?

CancelOK

Figure 164:  Changes Are Not Saved Dialog Box

5. If you select Cancel, the import procedure is aborted so
you can save the existing job.  If you select OK, the
import process continues.

6. The file is converted into the updated format and loaded
into GX-9100.  When conversion is complete, the
following dialog box appears:

Import is complete.

OK

GX9100

Figure 165:  Import Is Complete Dialog Box

7. Select OK.  You can then modify the configuration, if
necessary, and save it as a new .DXS file.
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Commissioning

For detailed commissioning procedures, see the Using a
Template File for Commissioning section of the EuroPRO
for Windows User’s Guide (Tab 4).
Among the procedures described in the document are:

• overriding, adjusting, and releasing points

• obtaining information for one or many controllers

• monitoring and graphing controller data

• customizing which points are displayed, their names,
units, and how they are grouped

• using a Template File to build a DDL CS Model

• an example Template File, with explanations
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Troubleshooting

When entering real numbers, the GX Tool for Windows
accepts any value between -32750 and 32750.  Numbers
with a modulus greater than 2048 may be rounded up or
down by up to 0.1 percent as shown in Table 28.

Table 28:  Rounding Factors
Range Rounding (+/-)

2049-4096 2
4097-8192 4
8193-16384 8

16385-32750 16

The rounding is due to the external communication bus
protocol and does not compromise the precision of the
internal control process.

The error message “The source and destination
points do not match!” appears.

• This is displayed when the source and destination points
are not of the same type (digital or analog).  Choose a new
source and/or destination point for this connection.

“The file could not be opened” message
appears.

• The software could not open a file; the file could
possibly be corrupted.  Use the backup file instead.

• The software could not find a file.  Check whether the
diskette is properly inserted in the diskette drive.

Values entered in a data window are gone when you return.

• You may have exited the window by clicking on Cancel
or pressing the Esc key before saving changes.  Make
sure to click on OK to save changes before exiting data
windows.

A Note on
Ranges

Common
Error
Messages
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When you exit a data window a message appears, asking you
to enter a number within a specific range, for example,
Please enter a number between 1 and 360.

• When real and integer values are entered into a data
window and you click on OK, the GX Tool checks the
values before it saves the changes.  If one of the values
is outside of the allowed range, the program will display
an error message defining the range of the point.  When
you click on OK to close the error message, the value
that needs to be changed will be highlighted.  Change
the value to one within the defined range and then click
on OK to exit the data window and save your changes.
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Appendix 1:  Source Points

ACOn The current value of an analog constant set
by a Supervisory System, the GX Tool, SX
Tool, or on the DX front panel.

AFB A “1” when the DO PAT associated feedback
value is not responding to changes in the DO
PAT command value.

AIn The current value of the analog input.
AI%n The current value of the analog input in

percent (%) of range.
AIHn A “1” if the analog input is above its high

limit and not below the high limit - limit
differential.

AILn A “1” if the analog input is below the low
limit and not above the low limit + limit
differential.

AOFn A “1” when an analog output is being
externally forced.

AOHn A “1” when the analog output is equal to or
above its high range.

AOLn A “1” when the analog output is equal to or
below its low range.

BATLOW A “1” when the DX lithium battery needs to
be replaced.

DCOn The current value of a digital constant set by
a Supervisory System, the GX Tool, SX Tool,
or on the DX front panel.

DIn The current status of the digital input.
DIAL When set to “1” by a set statement in the

PLC, this causes the N2 Dialer to connect the
N2 Bus to a Supervisory System via
telephone lines.  The DIAL bit will be reset
to “0” by the supervisory system when the
telephone line connection is successful.
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DICn Toggles from “0” to “1” or “1” to “0” when
the number of digital input transitions
(counts) equals the prescaler.

DOn The status of the digital output.
DOnC A “1” when the Supervisory System has

commanded the digital output to be On.
DOnE A “1” when the Supervisory System has

taken control of the digital output.
DOFn A “1” when the digital output PAT or DAT is

being externally forced.
DOHn A “1” when the digital output PAT or DAT is

at its defined high limit.
DOLn A “1” when the digital output PAT or DAT is

at its defined low limit.
HTRR Historical Trend Read Request.  A “1” when

any trend log buffer has reached its Read
Request limit.

LRSn The logic result status of an OUT, OUTNOT,
SET or RST statement in a PLC.

NAIn The analog numeric value that is received
over the LonWorks N2 Network.

NDIn-m The digital value that is received over the
LonWorks N2 Network.

NAIUn A “1” when the network analog shared value
is no longer receiving data from the
LonWorks N2 Network.

NDIUn A “1” when the network digital shared value
is no longer receiving data from the
LonWorks N2 Network.

OSnHEAT A “1” when Optimal Start module is in the
Heating mode.

OSnOUT A “1” when the Optimal Start module
requires equipment to be On. It is the
controlling output of an Optimal Start
module to START/STOP heating or cooling
equipment.
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OSnPRE A “1” while the Optimal Start module is in
the Pre-conditioning mode (will turn Off at
occupancy).

OSnSTO A “1” when the Optimal Start module is in
the Optimal Stop mode (will turn Off at
vacancy - unoccupancy).

OUHn A “1” when an analog or digital output is in
Hold mode from either the DX front panel or
Supervisory System.

OUTn The value of the analog output (including
PAT or DAT).

OVRn A “1” when the value of the analog input is
more than 5% above its normal range
(overrange condition).

PMnCMH A “1” when a control module’s output is
equal to its output high limit.

PMnCML A “1” when a control module’s output is
equal to its output low limit.

PMnCMP A “1” when the control module’s WSP is
being overridden by a Supervisory System
(Computer mode).

PMnDISm A “1” when the sequencer module output
stage is disabled.

PMnEF A “1” when this control module is being
externally forced.

PMnFSSm A “1” when the output of a channel of a
totalization module is at its full scale limit.

PMnHDA A “1” when the difference PV - WSP is
larger than the high deviation alarm value.

PMnHEAT A “1” when, in a symmetric control module,
the PV is below the center of the symmetry
band, and a “0” when above center; or a “1”
when, in a dual control module, Loop 1 is
active.

PMnHHDA A “1” when the difference PV - WSP is
larger than the high high deviation alarm
value.



174     Configuration Tools—GX-9100 User’s Guide

PMnHLD A “1” when the program module is in the
Hold mode, being overridden by the SX Tool
or a Supervisory System.

PMnHLDm A “1” when the channel of the program
module has been overridden (in hold) from
an SX service module or a Supervisory
System.

PMnLDA A “1” when the difference WSP - PV is
larger than the low deviation alarm value.

PMnLLDA A “1” when the difference WSP - PV is
larger than the low low deviation alarm
value.

PMnLSm A “1” when the comparator module channel
is at its comparison true logic state.

PMnLSP The value of the local setpoint.  (This value
is changed when adjusting the WSP from the
DX front panel.)

PMnLSP1 The value of the local setpoint of Loop 1 of a
dual control module.  (This value is directly
changed when adjusting the WSP1 from the
DX front panel.)

PMnLSP2 The value of the local setpoint of Loop 2 of a
dual control module.  (This value is changed
when adjusting the WSP2 from the DX front
panel.)

PMnMCSm A “1” as long as the maximum cycles status
timer for an output stage is active.

PMnMNWS The value of the minimum working setpoint
allowed for a control module.

PMnMXWS The value of the maximum working setpoint
allowed for a control module.

PMnNCM The calculation result of a numeric module.
PMnNCMm The calculation result of a channel of a

numeric module.
PMnNMH A “1” when the calculated output is equal to

or greater than the numeric module high
limit.
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PMnNMHm A “1” when the psychrometric numeric
module output is equal to or greater than the
high limit of the channel.

PMnNML A “1” when the calculated output is less than
or equal to the numeric module low limit.

PMnNMLm A “1” when the psychrometric numeric
module output is less than or equal to the low
limit of the channel.

PMnOCM The value of the PID control module output
in percent; either a “1” or “0” for an On/Off
control module.

PMnOCM1 The value of the Loop 1 output in a dual PID
control module in percent; either a “1” or “0”
for a Dual On/Off control module.

PMnOCM2 The value of the Loop 2 output in a dual PID
control module in percent; either a “1” or “0”
for a Dual On/Off control module.

PMnOUT The analog value of the requested output load
% (percent) of a sequencer.

PMnOUTD The output difference between the required
load minus the sum of the loads of stages that
are On in an Sequencer mode.  This can be
used for Vernier control.

PMnOUTS The analog value of the output sum of the
loads of stages that are On in an sequencer
module.

PMnSOF A “1” when this control module is in the
Shutoff mode, which occurs when “enable
shutoff = 1” and the Supervisory System has
commanded it On.

PMnSTA A “1” when this control module is in the
Startup mode, which occurs when “enable
startup = 1” and the Supervisory System has
commanded it On.

PMnSTOm A “1” when the staged output of a sequencer
module is requested to be On.

PMnTDOm A “1” when the numeric timer channel output
is On.
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PMnTIMm The numeric timer module timer value of
each channel.  It will be 0 when the channel
is not triggered or the timer has expired; or it
will be the number of seconds (or minutes, or
hours) left as the timer decrements.

PMnTOTm The totalized value of a totalization module
channel; the number of events, runtime, or
integration value.

PMnWSP The value of a control module working
setpoint.

PMnWSP1 The value of the working setpoint of Loop 1
of a dual control module.

PMnWSP2 The value of the working setpoint of Loop 2
of a dual control module.

SLF Serial Link Failure.  Set to “1” 60 seconds
after the last message from the Supervisory
System.

SOFF A “1” when the Supervisory System has
commanded the Shutoff mode.

SSA A “1” when the Supervisory System is active,
and returns to “0” two hours after the last
command from the Supervisory System.

STUP A “1” when the Supervisory System has
commanded the Startup mode.

TSnEXS A “1” when a time schedule module has its
extension enabled by a Supervisory System
or a DX front panel command.

TSnOUT A “1” when the real time is currently between
the start and stop times of an event of the
time schedule module and the current day is
specified for that event.

UNRn A “1” when the value of the analog input is
more than 5% below its normal range
(underrange condition).

XTnAIm The current value of the analog input from
the XT.
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XTnAIHm A “1” if the analog input is above its high
limit and not below the high limit - limit
differential.

XTnAILm A “1” if the analog input is below the low
limit and not above the low limit + limit
differential.

XTnAOm The value of the analog output to the XT.
XTnCOM A “1” when the extension module is not

communicating (wrong address, bus line
broken, or bus line overload).

XTnDIm The current status of the digital input from
the XT.

XTnDOn The status of the digital output to the XT.
XTnERR A “1” when the XT data base in the DX does

not match the XT data base in the expansion
module, or when XTnCOM is a “1”, or when
XTnHARD is a “1” (Versions 1.4, 2.3, 3.3 or
later). (Combination of errors for XT/XTM
module,  e.g., configuring an XP-9102 and
connecting an XP-9103 yields an error).

XTnFAIL The status of the Fail mode in the XT.  A “0”
indicates that outputs go to “0” on
communication failure and a “1” indicates
that the status of the outputs will be
maintained.

XTnHARD A “1” when the expansion module is not
connected or not responding (hardware fault).

XTnOUHm A “1” when an analog or digital output is in
Hold mode from either the DX front panel or
Supervisory System.

XTnPWR A “1” when the extension module detects a
loss of power or loss of communication.  The
DX will reset this after a few seconds.
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Appendix 2:
Destination Points

ALD@ The connection to disable alarm processing
on analog inputs AI1-AI8.

AO@ The numeric connection to control an analog
output.

AOF@ The connection to force an analog output to a
specified value.

DEC@ The connection to decrement an analog type
output, PAT/DAT digital type output or
sequencer module.  While connection is a
logic “1,” the output will decrease at a rate
dependent on the type of module.

DISn@ A connection in a sequencer to disable the
corresponding stage or set number.

DO@ The connection to control a digital output.
DOF@ The connection for forcing a digital output to

a specified value.
EF@ The connection to the external forcing point

of control modules.
ENL@ The connection to enable output limits of an

analog type output (PAT and DAT included).
FB@ The connection to the feedback of a PAT.

Usually a signal from a potentiometer on the
controlled device.

FST@ The connection to set the sequencer module
into fast step down mode.

HUMIDn@ The relative humidity sensor connections for
psychrometric calculations.

In@ Analog input connections to a programmable
module.
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INC@ The connection to increment an analog type
output, PAT/DAT digital type output or
sequencer module.  While connection is a
logic “1,” the output will increase at a rate
dependent on the type of module.

In-m@ Analog input connections to an 8-channel
calculator module.

MNWS@ The connection to the minimum working
setpoint of a control module.  The WSP
cannot be adjusted below this value.

MXWS@ The connection to the maximum working
setpoint of a control module.  The WSP
cannot be adjusted above this value.

NAOn@ The numeric source of a Network Analog
Output that is shared over the LonWorks N2
Network.

NDOn-m@ The logic connection to control a Network
Digital Output.

OB@ The connection of an output bias value of a
PID module.

OB1@ The connection for Loop 1 of a dual PID
output bias.

OB2@ The connection for the Loop 2 of a dual PID
output bias.

OF@ The connection to the Off mode source point
of a control module.

OSnDA@ The connection to disable the adaptive action
of an Optimal Start/Stop module.

OSnDI@ The connection to disable the Optimal
Start/Stop module.

OSnOB@ The connection to the Off Setpoint Bias,
which replaces the entered value when
connected in an Optimal Start/Stop module.

OSnOT@ The connection for the Outdoor Air
Temperature sensor of an Optimal Start/Stop
module.
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OSnSP@ The connection for the Optimal Start Zone
Temperature setpoint.  If connected, it
replaces the entered setpoint.

OSnTS@ The connection in an Optimal Start/Stop
module for the time schedule that determines
when the building is occupied.

OSnZT@ The connection for the Zone Temperature
sensor in an Optimal Start/Stop module.

PB@ The connection to proportional band, which
replaces the value PB if there is a connection.

PV@ The connection to the process variable of a
PID or an On/Off.

RA@ The connection to the reverse action point of
a control module.

RHn@ The relative humidity sensor connections for
psychrometric calculations.

RS@ The connection to a remote setpoint, which is
used in the calculation for the working
setpoint.

RSn@ The connection to the reset function of a
totalization module channel (to reset to 0 and
re-start) or timer module channel (to reset the
output).

RS1@ The connection for Loop 1 of a dual PID or
On/Off remote setpoint.

RS2@ The connection for Loop 2 of a dual PID or
On/Off remote setpoint.

RV@ The connection to reference variable which
is a multiplier in the calculation for the
working setpoint.

RV1@ The connection for Loop 1 of a dual PID or
On/Off reference variable.

RV2@ The connection for Loop 2 of a dual PID or
On/Off reference variable.

SB@ The connection to the stand by source point
of a control module.
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SPn@ A setpoint connection for a comparator
channel if a remote setpoint is desired,
otherwise the entered value for the setpoint
will be used.

TMn@ The temperature sensor connections for
psychrometric calculations.

TSnOF@ A connection to externally force the output of
a time schedule to Off.

TSnON@ A connection to externally force the output of
a time schedule to On.

TSnEX@ A connection to the external extension
override of a time schedule.
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Appendix 3:
Trend Log Items

Table 29 below lists the analog items and logic variables
that can be defined in a Trend Log Module for Metasys
Point History.  On the Metasys system, the analog inputs are
mapped to AI objects, the analog outputs to AOS objects,
and the logic variables to BI objects.
Table 30 on the next page lists the analog items and logic
variables that can be defined in a Trend Log Module for the
DX LCD Display.
Note: Since a logic variable set is recorded when any one of

its variables changes state, it is recommended that you
assign LRS logic variable bytes to the trend log and
then connect the source variables (the ones that you
wish to trend) to the LRS variables in a PLC module.

Table 29: Trend Log Items for Metasys Point 
History

DX Version Analog Items Logic Variables
1.4, 2.3 and later AI1 to AI8

OUT1 to OUT8
ACO1 to ACO8
XTnAI1 to XTnAI8*
XTnAO1 to XTnAO8*

DI1..8
LRS1..8
LRS9..16
LRS17..24
LRS25..32
XTnDI1..XTnDI8*

2.3 and later only OUT9 to OUT14 –
*Requires Metasys Release 11 or later.
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Table 30:  Trend Log Items for DX LCD Display
DX Version Analog Items Logic Variables
2.3, 3.3 and later AI1 to AI8

OUT1 to OUT14
ACO1 to ACO8
XTnAI1 to XTnAI8
XTnAO1 to XTnAO8
PMnK1 to PMnK34
PMnOU1 to PMnOU8
PMnAX1, PMnAX2

DI1..8
LRS1..8
LRS9..16
LRS17..24
LRS25..32
LRS33..40
LRS41..48
LRS49..56
LRS57..64
DO3..8
DCO1..8
DCO9..16
DCO17..24
DCO25..32
XTnDI1..8
XTnDO1..8
AIH1..4
AIH5..8
AIL1..4
AIL5..8
XTnAIH1..4
XTnAIH5..8
XTnAIL1..4
XTnAIL5..8
PMnDO1..8

3.3 and later only NAI1 to NAI16 NDI1-1..8
NDI1-9..16
NDI2-1..8
NDI2-9..16
NDI3-1..8
NDI3-9..16
NDI4-1..8
NDI4-9..16
NDI5-1..8
NDI5-9..16
NDI6-1..8
NDI6-9..16
NDI7-1..8
NDI7-9..16
NDI8-1..8
NDI8-9..16
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Appendix 4:
DX LCD Display Items

The tables in this appendix list the DX controller items that
can be included in the DX LCD Display point data base.

Table 31:  DX-9100/DX-9120 Hardware Points
Tag Name Command Description
AI1-8 No Analog Input 1-8
DI1-8 No Digital Input 1-8
OUT1-2 Yes Analog Output 1-2
DO3-8 Yes Digital Output 3-8
OUT3-8 Yes Value of Analog Source DO3-8
OUT9-14 Yes Analog Outputs 9-14

Table 32:  XT-9100 Hardware Points
Tag Name Command Description
XTnAI1-8 No XTn Analog Input 1-8
XTnDI1-8 No XTn Digital Input 1-8
XTnAO1-8 Yes XTn Analog Output 1-8
XTnDO1-8 Yes XTn Digital Output 1-8
n = 1-8

Table 33:  DX-9120 Network Inputs/Outputs
Tag Name Command Description
NAI1-16 Yes* Network Analog Input 1-16
NDIm-n Yes* Network Digital Inputs
NAO1-16 No Network Analog Output 1-16
NDOm-n No Network Digital Outputs
m = 1-8 (module)
n = 1-16 (input/output)
* Use the Command option for testing and commissioning

purposes only.  During normal operation, the input is set by a
network output of another controller on the network.
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Table 34:  DX-9100/DX-9120 Internal Points
Tag Name Command Description
SOFF Yes Shut off
STUP Yes Start up
DIAL Yes Dial-up Flag
CNT1-8 Yes Counter Value 1-8
XTnCNT1-8 Yes Counter Value XTn Digital Input 1-8
HIA1-8 Yes Value of High Limit Analog Input 1-8
LOA1-8 Yes Value of Low Limit Analog Input 1-8
XTnHIA1-8 Yes Value of High Limit

XTn Analog Input 1-8
XTnLOA1-8 Yes Value of Low Limit

XTn Analog Input 1-8
ADF1-8 Yes Value of Alarm Differential

Analog Input 1-8
AIH1-8 No High Alarm Flag Analog Input 1-8
AIL1-8 No Low Alarm Flag Analog Input 1-8
XTnAIH1-8 No High Alarm Flag XTn Analog Input 1-8
XTnAIL1-8 No Low Alarm Flag XTn Analog Input 1-8
DCO1-32 Yes Digital Constant 1-32
ACO1-8 Yes Analog Constant 1-8
LRS1-64 No Logic Result Status 1-64
n = 1-8

Table 35:  Programmable Module Items
Tag Name Command Description
PMmK1-34 Yes Module Constant 1-34
PMmOU1-8 Yes Module Output 1-8
PMmAX1-2 Yes Auxiliary Output 1-2
PMmCT1-8 Yes Hold Control 1-8
PMmDO1-8 Yes Module Logic Output 1-8
PMmS1-16 No Module Status 1-16
PMmAC1-8 Yes Accumulator 1-8
m = 1-12
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Appendix 5:  Abbreviations

4-SEGM 4 Channel Segment Module (4 break points
each)

8-CALC 8 Channel Calculator Module
ACO Analog Constant
AI Analog Input
AO Analog Output
AVERAGE Average Calculation Module
BIN-SEQ Binary Code Sequencer
CALC Calculation Module
COMPRTR Comparator
D-ONOFF Dual On/Off (Heating and Cooling)
D-PID Dual Proportional, Integral and Derivative

Controller (2 Loops for Heating and Cooling)
DCO Digital Constant
DI Digital Input
DO Digital Output
EXD Exception Days
EXP Expansion Module (XP2) for XT or XTM
LRS Logic Result Status
MAXIMUM Maximum Select Module
MINIMUM Minimum Select Module
NAI Network Analog Input
NAO Network Analog Output
NDI Network Digital Input
NDO Network Digital Output
ONOFF On/Off
OS Optimal Start/Stop
PID Proportional, Integral and Derivative

Controller
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PLC Programmable Logic Controller
PM Programmable Module
PSYCHRO Psychrometric
SEGMENT Segment Module (17 break points)
SELECT 4 Input Select Module
SEQ Sequencer
STA/STO Start/Stop
TIMER 8 Channel Time Module
TOTAL Totalization
TS Time Schedule Module
XT XT-9100 Extension Module (includes XP1)
XTM XTM-905 Extension Module (includes XP1)
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Appendix 6:  Comparison
with the DOS Version

Table 36:  Comparison with the DOS Version
DOS Version
Command

Windows Version Command
(Menu Option and Keyboard
Shortcut)

Tool Bar Button or
Mouse Action
(where applicable)

INFO Edit -- Job Information
PRINT File -- Print

DOWNLD Action -- Download
UPLOAD Action -- Upload
SAVE File -- Save

READ File -- Open

NEW File -- New

CALIBR. Edit -- Calibration
REDRAW (No equivalent command -- screen

refreshes automatically.)
VERSION Controller -- DX Version 1.1, 1.2, 1.3

Controller -- DX Version 1.4
Controller -- DX Version 2.0, 2.1, 2.2
Controller -- DX Version 2.3
Controller -- DX Version 3.0, 3.1, 3.2
Controller -- DX Version 3.3

GLOBAL Edit -- Global Data
QUIT File -- Exit
SOURCE Edit – Connect, or

F5 key
Click and drag the bent
arrow from the source
point to the destination
point.

DATA Edit -- Data
DELETE Edit -- Delete
CONN View -- Show Connections
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Appendix 7:
Custom Home Page

The Home Page is intended for use as a graphic display of
important parameters that you want to show as the default
screen.  The Home Page displays static and dynamic
graphics, which can include changing symbols, bar graphs,
and characters in any language.
The Home Page is defined in an ASCII file format with
references to bitmap files.  The GX Tool reads the Home
Page definition file (*.hpg) and downloads the required
bitmaps (*.bmp) and other related information to the DX
LCD Display panel (see Downloading a Configuration to
the DX LCD Display earlier in this document).  The DX
LCD Display can store up to eight different Home Pages.
When you open a configuration file in the GX Tool, it
automatically looks for a home page file with the same name
as the configuration file but with the .hpg extension.  For
example, if you open a configuration file named
config1.dxs, the tool automatically opens the Home
Page file named config1.hpg.
Note: The GX Tool downloads a default Home Page (named

default.hpg) to the DX LCD display if it cannot
find a custom Home Page with the same name as the
open configuration file.

hh:mm

default

Figure 166:  Default Home Page
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You have complete control over the contents of the Home
Page.  Apart from referencing user-created bitmaps, the
Home Page can also reference standard bar graph symbols
available in the DX LCD Display.  You can associate analog
and digital items with these images.
The individual contents of the Home Page are described
under separate sub-headings in the remainder of this section.

Dynamic text for the display of numeric items can be
included in the Home Page.  Dynamic text is typically
associated with analog items such as AI1, clock time, etc.
The text can be displayed in one of three font sizes.  The
various sizes are:

• small - 6 pixels wide by 8 pixels high

• medium - 12 pixels wide by 16 pixels high

• large - 24 pixels wide by 32 pixels high
When you load a Home Page file, the GX Tool verifies that
no text goes beyond the limits of the LCD display (240
pixels wide by 128 pixels high).

These are normally used as the background of the Home
Page.  Labels, units and any other static text can be a part of
the static bitmap.  The bitmap is created using any standard
bitmap editor and the .bmp file is referenced in the Home
Page definition file.

These are associated with digital items.  Different bitmaps
are associated with state 0 and state 1.  This feature can be
used to display changing images that represent the states of
the digital item.  You create the state 0 and state 1 bitmaps
so you have complete control over their appearance.

A bar graph can be linked to an analog item.  You specify
the values of the analog source for 0% and 100%.  The bar
size changes as the input changes from 0% to 100%

This type is used to display the most recent alarm and the
total number of alarms in the small font size on any line of
the Home Page.

Home Page
Content

Text

Static Bitmaps

Dynamic
Bitmaps

Bar Graph

Alarm Line
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This type is used to display the current time in 12-hour
(hh:mm a/p) or 24-hour (hh:mm) format in the small,
medium, or large font size on the Home Page.

Use any standard ASCII text editor (such as Windows
Notepad) to create the Home Page definition file.  Give the
file the same name as the associated DX configuration file
but use a .hpg file name extension.  Use any standard paint
program (such as Windows Paintbrush) to create
monochrome Windows bitmap files (.bmp).  The syntax for
the Home Page definition file is described under the next
sub-heading.

The syntax rules for defining a Home Page are presented in
this section.  When you load the Home Page file into the GX
Tool, it performs a syntax check and lists any errors or
warnings that it finds in the file (see Downloading a
Configuration to the DX LCD Display earlier in this
document).  An example of a Home Page definition file
follows at the end of this section.

Tokens
Tokens are shown in angle brackets (<>), and are used as
placeholders in the statement rules.  Wherever a token
appears in a rule, replace it with an appropriate value, taking
the ranges or possible choices into account.  The tokens are
listed in Table 37, and the special characters that can be used
in the definition file are listed in Table 38.

Clock

Home Page
Definition File

Home Page
Definition File
Syntax
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Table 37:  Tokens
Token Values Description
<row> 1 to 128 pixel row of display
<col> 1 to 240 pixel column of display
<bmp top l row/col> 1 to 65535 top left row/column offset of

image in bitmap file
<bmp bot r row/col> 1 to 65535 bottom right row/column

offset of image in bitmap
file

<height> 1 to 128 height in pixels
<width> 1 to 240 width in pixels
<font_size> SMALL

MEDIUM
LARGE

6 x 8 pixel font
12 x 16 pixel font
24 x 32 pixel font

<orientation> HORIZONTAL
VERTICAL

bar graph orientation

<show status> STATUS
NO_STATUS

specifies whether or not to
display the analog item’s
status

<12_24_format> 12
24

12-hour time format
24-hour time format

<name> string enclosed in double
quotes

Table 38:  Special Characters
Character Description
carriage return delimiter for each line
\ used for continuation of any line
* placed at beginning of line for single line

comment (multiple line comments are not
allowed)
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Statements
Most statements place elements on the Home Page.  For
static backgrounds and digital items, where you specify a
bitmap file name, you must also specify the offset of the
image within the bitmap file.  This is very useful if you want
to store all of the Home Page images in one bitmap file, and
then refer to different images in the file by specifying their
coordinates.

Begin Home Page Definition
BEGIN_HOMEPAGE <name>

The <name> is not downloaded to the DX LCD Display.  It
serves only as an identifier for the Home Page definition.

End Home Page Definition
END_HOMEPAGE

Static Bitmap
<row> <col> STATIC \

<bmp top l row> <bmp top l col> \
<bmp bot r row> <bmp bot r col> <bitmap file>

The bitmap must be monochrome.

Analog Item
<row> <col> ANALOG <font size> <no of digits after decimal point> \

<show status> <item tag>
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Digital Item
<row> <col> DIGITAL \

<bmp top l row> <bmp top l col> \
<bmp bot r row> <bmp bot r col> <bitmap file for off> \
<bmp top l row> <bmp top l col> \
<bmp bot r row> <bmp bot r col> <bitmap file for on> \
<bmp top l row> <bmp top l col> \
<bmp bot r row> <bmp bot r col> <bitmap file for override off> \
<bmp top l row> <bmp top l col> \
<bmp bot r row> <bmp bot r col> <bitmap file for override on> \
<item tag>

The OFF (state 0) and ON (state 1) bitmaps must be the
same size.  Similarly, the override OFF and override ON
bitmaps must be the same size.  If an override OFF bitmap is
specified, then an override ON bitmap is also required.  All
bitmaps must be monochrome.
For digital input type items, you do not have to specify
bitmap files for override OFF and override ON, i.e., you can
omit them from the DIGITAL statement.
For digital output type items, you must specify override OFF
and override ON bitmap files.  They can, however, be the
same bitmaps as the normal OFF and ON bitmaps.  The
override bitmaps are displayed at the same position as the
OFF and ON bitmaps, i.e., they replace them on the display.

Alarm Line
<row> ALARM_LINE

The ALARM_LINE begins at the first column and has a
height of 8 pixels.  Only one alarm line is allowed on a
Home Page.  The row for the alarm line must be a multiple
of 8.

Bar Graph
<row> <col> BARGRAPH <width> <height> <orientation> \

<src val for 0%> <src val for 100%> <item tag>

A rectangle is drawn around the bar graph by leaving a one
pixel gap on each side to indicate the bar graph’s boundary.
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Clock
<row> <col> CLOCK <font_size> <12_24_format>

For 12-hour format the clock occupies 6 characters
(hh:mm a/p) and for 24-hour format it occupies 5 characters
(hh:mm) of the size defined by <font_size>.

Home Page Definition File Example
The custom Home Page example is shown in Figure 167:

50%RH22°C
FAN = ON
COOLING = ON
HEATING = OFF
HUMIDIFIER = OFF
DEHUM. = OFF

Figure 167:  Home Page Example

The Home Page definition file for Figure 167 is shown
below:

*
* put all rectangles, units and fixed text in the static bitmap
*
BEGIN_HOMEPAGE “plant1”
0 0 STATIC 2 2 129 241 “plant1.bmp”
10 10 ANALOG LARGE 0 NO_STATUS AI1
10 130 ANALOG LARGE 0 NO_STATUS AI2
72 170 DIGITAL 140 2 147 13 “plant1.bmp” 150 2 157 13 “plant1.bmp” DI1
80 170 DIGITAL 140 2 147 13 “plant1.bmp” 150 2 157 13 “plant1.bmp” DI2
88 170 DIGITAL 140 2 147 13 “plant1.bmp” 150 2 157 13 “plant1.bmp” DI3
96 170 DIGITAL 140 2 147 13 “plant1.bmp” 150 2 157 13 “plant1.bmp” DI4
104 170 DIGITAL 140 2 147 13 “plant1.bmp” 150 2 157 13 “plant1.bmp” DI5
END_HOMEPAGE
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Table 39 lists the DX LCD Display (DT-9100) Homepage
definition errors and solutions.

Table 39: Homepage Definition Errors
Error Message Syntax Check

Message
Solution

Bitmap File Type Error Line :6 Bitmap
Error, only
mono-chromes are
supported

Reopen the bitmap file in Paint. Change
Save As type to Monochrome Bitmap and
resave.

Bitmap file not
found

Error Line :6 Bitmap
file not found

The Homepage file (*.hpg) references a
bitmap file (*.bmp) that is not located in the
same directory. Locate bitmap file in the
same directory as the Homepage file.

Bitmap
dimension
mismatch, Bitmap
is smaller than
that specified

Error Line :6 Bitmap
is smaller than that
specified

Increase the bitmap file size to match the
homepage definition. The bitmap file can be
larger than what is defined without producing
an error. The DT-9100 displays only what
appears in the area up to 240 pixels wide by
128 pixels high.

Multiple alarm
lines

Error Line :42
Multiple alarm lines
not allowed.

Delete all but one alarm line.

Overlapping area Error Line :42
Overlap error, at
least two areas
overlap, dynamic
data items, Digital,
Analog

The overlapping items could be analog or
digital. To determine overlapping areas, open
the static bitmap file and locate the dynamic
item referenced in the error line. Locate other
dynamic items near the referenced item.
Check the coordinates from the definition of
the items in the Homepage file (coordinate
refers to location of the upper left corner of
the dynamic item and its font size). Relocate
the referenced item so it does not contact
another item.

Statement type
not recognized

Error Line :33
Statement type not
recognized. DO, DI,
Digital

Digital items typically use backslash ( \ ) as
part of the definition. Verify backslash used
for line continuation includes space before
special character.
Example: 90 160 DIGITAL \

141 22 151 63 “DX-22.BMP” \
129 22 139 63 “DX-22.BMP” \
DO3

Continued on the next page…

Homepage
Definition
Errors
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Error Message
(Cont.)

Syntax Check
Message

Solution

Not enough space
to show ANALOG
item

Warning Line :11
Not enough space
to show ANALOG
item

Dynamic Analog item is overlapping an area
of the static bitmap that contains an image.
Relocate the Analog item. To determine the
overlapping area, open the static bitmap file
and locate the analog item referenced in the
Error line. Locate the static image (i.e. labels
units, text, etc.) near the analog item. Check
the coordinates from the definition of the
analog item in the Homepage file (coordinate
refers to location of the upper left corner of
the dynamic item and its font size).

Number of
Parameters not
correct for type
DIGITAL

Error line :30
Number of
Parameters not
correct for type
DIGITAL

Digital items typically use backslash ( \ ) as
part of the definition. Verify backslash used
for line continuation includes space before
special character.
Example: 90 160 DIGITAL \

141 22 151 63 “DX-22.BMP” \
129 22 139 63 “DX-22.BMP” \
DO3
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Appendix 8: Customizing the
DX LCD Display Main Menu

The DX LCD Display Main Menu can be customized so that
certain features do not appear. This may be desirable for
OEM customers who do not require certain functions
normally supported by the DX LCD Display, such as time
programs or Optimal Start/Stop.
This is done by changing the text in the GX language file
(dxmisc.lng) so that the length of a menu description is
equal to zero and the corresponding menu is not shown.
Open the GX language file (dxmisc.lng) in an ASCII text
editor (such as Wordpad or Notepad). Any of the menus in
lines 16068 to 16078 of the file may be hidden by removing
the menu text between quotation marks.
In the example below, Line 16075 for Optimal Start/Stop
has been altered so that Optimal Start Stop will not appear in
the DX LCD Display Main Menu. The line was duplicated,
so there are two of the same. A star was placed in front of
the first Line 16075 to disable it. In the second Line 16075,
which is enabled, Optimal Start/Stop was deleted so that
nothing appears between the sets of quotation marks (""). By
duplicating the line and editing it as shown below, the menu
can be easily added again, when required.
.
.
.
* Max Allowed length 28

16068 0 0 0 0 "Home Page"

16069 0 0 0 0 "Point Data"

16070 0 0 0 0 "Alarm Summary"

16071 0 0 0 0 "Alarm Log"

16072 0 0 0 0 "Trend Data"

16073 0 0 0 0 "Time Schedules"

16074 0 0 0 0 "Holidays"

* 16075 0 0 0 0 "Optimal Start/Stop"

16075 0 0 0 0 ""

16076 0 0 0 0 "Time/Date"

16077 0 0 0 0 "Password"

16078 0 0 0 0 "Choose Controller"
.
.
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Be sure to save your changes to the file before closing it.
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Appendix 9: Updating DX
LCD Display Firmware

A DT-9100 with firmware Version 3.00.00 or higher can be
updated via the DX LCD Display - Update Firmware menu,
if the option has been enabled in the GX9100.INI file.
(See the Software Installation section for more details.)

!   CAUTION: All configuration data in the DT-9100
will be lost after updating the firmware.
To avoid data loss, upload and save to
disk all configurations and home pages
from the DT-9100 before updating the
firmware.

1. Select Update Firmware from the DX-LCD Display
menu. The Update Firmware dialog box shown below
appears:

Figure 168:  Firmware Update Dialog Box

DX LCD Display - Update Firmware

Folders:

c:\progra~1\gx_beta\prm

c:\
Cancel

OK

Drives:

progra~1

File name:

30007~1.prm

List files of type:

Firmware files (*.PRM) c: hard disk

 *.prm

30008~1.prm

gx_beta
 prm

?

gxchoose



204     Configuration Tools—GX-9100 User’s Guide

2. Choose the file name and press OK to continue. The
DOS window shown below appears:

Figure 169: DOS Window

3. Press <0> (zero) to abort the download procedure and
return to the GX Tool, or press the <return > key to start
the download procedure. If you press the <return> key,
the DT-9100 will reset and the screen will be blank. Then
the download will begin, as shown in the diagram below:

Figure 170: Download Starting

dtdoswin

dtdwnst



Configuration Tools—GX-9100 User’s Guide     205

4. When the download is complete, the following screen
will appear and the DT-9100 will reset.

Figure 171: Download Complete

5. Close the download window to return to the GX Tool.

dtdwncmp
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